<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<title>Linux or Windows: 25 Things You Must Know While Choosing The Best Platform</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.ubuntupit.com/xmlrpc.php" />
<meta property="og:image" content="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-25-Things-You-Must-Know-While-Choosing-The-Best-Platform.png" /><link rel="icon" type="image/png" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/favicon.ico"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/apple-icon-76x76.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/apple-icon-120x120.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/apple-icon-152x152.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/apple-icon-114x114.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/apple-icon-144x144.png" />

<meta name="description" content="Linux or Windows; Which one is the better platform for you? This query may start an ever ending discussion; is a complicated and challenging as well." />
<link rel="canonical" href="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/" />
<link rel="publisher" href="https://plus.google.com/+UbuntuPIT" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Linux or Windows: 25 Things You Must Know While Choosing The Best Platform" />
<meta property="og:description" content="Linux or Windows; Which one is the better platform for you? This query may start an ever ending discussion; is a complicated and challenging as well." />
<meta property="og:url" content="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/" />
<meta property="og:site_name" content="UbuntuPIT" />
<meta property="article:publisher" content="https://www.facebook.com/UbuntuPIT" />
<meta property="article:author" content="https://facebook.com/UbuntuPIT" />
<meta property="article:tag" content="Comparison Post" />
<meta property="article:tag" content="Distro Review" />
<meta property="article:section" content="Distros" />
<meta property="article:published_time" content="2018-08-05T00:17:59+00:00" />
<meta property="article:modified_time" content="2018-08-09T19:04:55+00:00" />
<meta property="og:updated_time" content="2018-08-09T19:04:55+00:00" />
<meta property="fb:app_id" content="141578016573091" />
<meta property="og:image" content="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-25-Things-You-Must-Know-While-Choosing-The-Best-Platform.png" />
<meta property="og:image:secure_url" content="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-25-Things-You-Must-Know-While-Choosing-The-Best-Platform.png" />
<meta property="og:image:width" content="725" />
<meta property="og:image:height" content="331" />
<meta property="og:image:alt" content="Linux or Windows: 25 Things You Must Know While Choosing The Best Platform" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Linux or Windows; Which one is the better platform for you? This query may start an ever ending discussion; is a complicated and challenging as well." />
<meta name="twitter:title" content="Linux or Windows: 25 Things You Must Know While Choosing The Best Platform" />
<meta name="twitter:site" content="@UbuntuPIT" />
<meta name="twitter:image" content="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-25-Things-You-Must-Know-While-Choosing-The-Best-Platform.png" />
<meta name="twitter:creator" content="@UbuntuPIT" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Person","url":"https:\/\/www.ubuntupit.com\/","sameAs":["https:\/\/www.facebook.com\/UbuntuPIT","https:\/\/plus.google.com\/+UbuntuPIT","https:\/\/twitter.com\/UbuntuPIT"],"@id":"#person","name":"Mehedi Hasan"}</script>
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.ubuntupit.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.ubuntupit.com\/category\/distros\/","name":"Distros"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/www.ubuntupit.com\/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform\/","name":"Linux or Windows: 25 Things You Must Know While Choosing The Best Platform"}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="UbuntuPIT &raquo; Feed" href="https://www.ubuntupit.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="UbuntuPIT &raquo; Comments Feed" href="https://www.ubuntupit.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="UbuntuPIT &raquo; Linux or Windows: 25 Things You Must Know While Choosing The Best Platform Comments Feed" href="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ubuntupit.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='td-plugin-newsletter-css' href='https://www.ubuntupit.com/wp-content/plugins/td-newsletter/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.ubuntupit.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=72ece2de773553959e5098a544851753' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Poppins%3A400%7CBlack+Ops+One%3A400%7CLato%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='fixedtoc-style-css' href='https://www.ubuntupit.com/wp-content/plugins/fixed-toc/frontend/assets/css/ftoc.min.css?ver=4.9.8' type='text/css' media='all' />
<style id='fixedtoc-style-inline-css' type='text/css'>
#ftwp-container.ftwp-fixed-to-post.ftwp-top-right #ftwp-trigger, #ftwp-container.ftwp-fixed-to-post.ftwp-top-right #ftwp-contents { top: 50px; } #ftwp-container.ftwp-wrap #ftwp-contents { width: 250px; height: auto; font-size: 12px; } #ftwp-container.ftwp-wrap #ftwp-trigger { width: 49px; height: 49px; font-size: 29.4px; } #ftwp-container #ftwp-trigger.ftwp-border-bold { font-size: 26.9px; } #ftwp-container.ftwp-wrap #ftwp-header { font-size: 19.2px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-header-title { font-weight: bold; } #ftwp-container.ftwp-wrap #ftwp-list { font-size: 12px; font-family: inherit; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor::before { font-size: 4.8px; } #ftwp-container #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor .ftwp-text { font-size: 13.2px; } #ftwp-container.ftwp-wrap #ftwp-list.ftwp-strong-first>.ftwp-item>.ftwp-anchor::before { font-size: 6px; } #ftwp-container.ftwp-wrap #ftwp-trigger { color: #333333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-trigger { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents { border-color: rgba(51,51,51,0.95); } #ftwp-container.ftwp-wrap #ftwp-header { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-header { background: #f3f3f3; } #ftwp-container.ftwp-wrap #ftwp-list { color: #333; background: rgba(243,243,243,0.95); } #ftwp-container.ftwp-wrap #ftwp-contents:hover #ftwp-list { background: #f3f3f3; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:hover { color: #dd3333; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-anchor:focus, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active, #ftwp-container.ftwp-wrap #ftwp-list .ftwp-active:hover { color: #fff; } #ftwp-container.ftwp-wrap #ftwp-list .ftwp-text::before { background: rgba(221,51,51,0.95); } .ftwp-heading-target::before { background: rgba(221,51,51,0.95); }
</style>
<link rel='stylesheet' id='td-theme-css' href='https://www.ubuntupit.com/wp-content/themes/Newspaper/style.css?ver=9.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css' href='https://www.ubuntupit.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=dc11e23cd0219f30e55307de07f135fc' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ubuntupit.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ubuntupit.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ubuntupit.com/wp-content/plugins/wp-quads-pro/assets/js/ads.js?ver=1.8.0'></script>
<link rel='https://api.w.org/' href='https://www.ubuntupit.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ubuntupit.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ubuntupit.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.ubuntupit.com/?p=5992' />
<link rel="alternate" type="application/json+oembed" href="https://www.ubuntupit.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ubuntupit.com%2Flinux-or-windows-25-things-you-must-know-while-choosing-the-best-platform%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ubuntupit.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ubuntupit.com%2Flinux-or-windows-25-things-you-must-know-while-choosing-the-best-platform%2F&#038;format=xml" />
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.ubuntupit.com\/wp-admin\/","wpRestNonce":"762ed28d58","wpRestUrl":"https:\/\/www.ubuntupit.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<link rel="amphtml" href="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/amp/">

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-107486790-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-107486790-1');
</script><link rel="icon" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/cropped-apple-icon-152x152-1-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/cropped-apple-icon-152x152-1-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.ubuntupit.com/wp-content/uploads/2018/07/cropped-apple-icon-152x152-1-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.ubuntupit.com/wp-content/uploads/2018/07/cropped-apple-icon-152x152-1-300x300.png" />

<style>
    .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                  color: #ff0000;
                }
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                  background-color: #ff0000;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #ff0000;
                }
                .tdm-btn-style1 {
					background-color: #ff0000;
				}
				.tdm-btn-style2:before {
				    border-color: #ff0000;
				}
				.tdm-btn-style2 {
				    color: #ff0000;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #ff0000;
                    -moz-box-shadow: 0 2px 16px #ff0000;
                    box-shadow: 0 2px 16px #ff0000;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #ff0000;
                    -moz-box-shadow: 0 4px 26px #ff0000;
                    box-shadow: 0 4px 26px #ff0000;
				}
				
				
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a {
                  color: #dd3333;
                }
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
                .tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a {
                  border-color: #dd3333;
                }
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-menu-item > a,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > li > a:hover,
                .tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .sfHover > a {
                  background-color: #dd3333;
                }
</style>
<style id="tdw-css-placeholder"></style></head>
<body class="post-template-default single single-post postid-5992 single-format-standard tdm-menu-active-style5 linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform global-block-template-9 tdb_template_6344 has-ftoc td-animation-stack-type1 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://facebook.com/UbuntuPIT" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://plus.google.com/+UbuntuPIT" title="Google+">
<i class="td-icon-font td-icon-googleplus"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#86ebe3eee3e2efb3b1c6e1ebe7efeaa8e5e9eb" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/UbuntuPIT" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-3082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-3082"><a href="https://www.ubuntupit.com/category/tutorials/">Tutorial</a></li>
<li id="menu-item-3080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3080"><a href="https://www.ubuntupit.com/category/software/">Software</a></li>
<li id="menu-item-3081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3081"><a href="https://www.ubuntupit.com/category/themes/">Themes</a></li>
<li id="menu-item-5875" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5875"><a href="https://www.ubuntupit.com/category/distros/">Distros</a></li>
<li id="menu-item-6149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6149"><a href="https://www.ubuntupit.com/category/top-list/">Top List</a></li>
<li id="menu-item-6151" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6151"><a href="https://www.ubuntupit.com/category/gaming/">Gaming</a></li>
<li id="menu-item-5439" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-5439"><a href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/">Best Linux Apps</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.ubuntupit.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">

<div class="td-header-wrap td-header-style-5 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="td_data_time">
<div>
Monday, September 24, 2018
</div>
</div>
<div class="menu-top-container"><ul id="menu-top-menu" class="top-header-menu"><li id="menu-item-6153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-6153"><a href="https://www.ubuntupit.com/about-me/">About Me</a></li>
<li id="menu-item-6152" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6152"><a href="https://www.ubuntupit.com/contact-us/">Contact US</a></li>
<li id="menu-item-6174" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-6174"><a href="https://www.ubuntupit.com/how-to-disable-adblockers/">Support US</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://facebook.com/UbuntuPIT" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://plus.google.com/+UbuntuPIT" title="Google+">
<i class="td-icon-font td-icon-googleplus"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#c1aca4a9a4a5a8f4f681a6aca0a8adefa2aeac" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/UbuntuPIT" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div> </div>

</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap ">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-menu">
<a class="td-main-logo" href="https://www.ubuntupit.com/">
<img class="td-retina-data" data-retina="https://www.ubuntupit.com/wp-content/uploads/2018/09/UbuntuPIT-Retina-Logo-Linux-Fighter.png" src="https://www.ubuntupit.com/wp-content/uploads/2018/09/UbuntuPIT-Main-Logo-Linux-Fighter-Full-White.png" alt="UbuntuPIT.com" title="Linux Software, Tutorials & Open Source Trends" />
<span class="td-visual-hidden">UbuntuPIT</span>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-3082"><a href="https://www.ubuntupit.com/category/tutorials/">Tutorial</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3080"><a href="https://www.ubuntupit.com/category/software/">Software</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3081"><a href="https://www.ubuntupit.com/category/themes/">Themes</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-5875"><a href="https://www.ubuntupit.com/category/distros/">Distros</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6149"><a href="https://www.ubuntupit.com/category/top-list/">Top List</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6151"><a href="https://www.ubuntupit.com/category/gaming/">Gaming</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-post td-menu-item td-normal-menu menu-item-5439"><a href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/">Best Linux Apps</a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.ubuntupit.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div> <div class="td-main-content-wrap td-container-wrap">
<div class="tdc-content-wrap">
<article id="post-6344" class="post-6344 tdb_templates type-tdb_templates status-publish post post-ftoc" itemscope itemtype="https://schema.org/Article">
<div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-top-right"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-bold" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-menu"></span></button><nav id="ftwp-contents" class="ftwp-shape-square ftwp-border-bold"><header id="ftwp-header"><span id="ftwp-header-control" class="ftwp-icon-menu"></span><button type="button" id="ftwp-header-minimize"></button><h3 id="ftwp-header-title">CONTENTS</h3></header><ol id="ftwp-list" class="ftwp-liststyle-none ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first"><li class="ftwp-item ftwp-has-sub"><a class="ftwp-anchor" href="#linux-or-windows-which-one-is-the-best-platform"><span class="ftwp-text">Linux or Windows: Which One is the Best Platform?</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#1-linux-or-windows-basic-foundation"><span class="ftwp-text">1. Linux or Windows: Basic Foundation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#2-system-stability"><span class="ftwp-text">2. System Stability</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#3-hardware-support"><span class="ftwp-text">3. Hardware Support</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#4-linux-or-windows-targeted-user-group"><span class="ftwp-text">4. Linux or Windows: Targeted User Group</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#5-f-o-s-s-vs-proprietary"><span class="ftwp-text">5. F.O.S.S vs. Proprietary</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#6-linux-vs-windows-security-and-privacy"><span class="ftwp-text">6. Linux vs Windows Security and Privacy</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#7-antivirus-and-malware-threat"><span class="ftwp-text">7. Antivirus and Malware Threat</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#8-linux-or-windows-customization"><span class="ftwp-text">8. Linux or Windows: Customization</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#9-administrative-privilege-and-root-access"><span class="ftwp-text">9. Administrative Privilege and Root Access</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#10-programming-platform-for-developers"><span class="ftwp-text">10. Programming Platform for Developers</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#11-install-update-and-upgrade"><span class="ftwp-text">11. Install, Update and Upgrade</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#12-different-flavors-for-different-need"><span class="ftwp-text">12. Different Flavors for Different Need</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#13-linux-or-windows-gaming-area"><span class="ftwp-text">13. Linux or Windows: Gaming Area</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#14-software-availability-and-compatibility"><span class="ftwp-text">14. Software Availability and Compatibility</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#15-photoshop-alternative"><span class="ftwp-text">15. Photoshop Alternative</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#16-alternative-to-office-suite"><span class="ftwp-text">16. Alternative To Office Suite</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#17-multimedia-editor"><span class="ftwp-text">17. Multimedia Editor</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#18-support-of-windows-software-via-wine-or-playonlinux"><span class="ftwp-text">18. Support of Windows Software via Wine or PlayOnLinux</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#19-software-management-system"><span class="ftwp-text">19. Software Management System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#20-linux-server-or-windows-server"><span class="ftwp-text">20. Linux Server or Windows Server</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#21-blue-screen-and-de-fragmentation"><span class="ftwp-text">21. Blue Screen and De-fragmentation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#22-file-extension-to-run-the-file"><span class="ftwp-text">22. File Extension To “run” The File</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#23-linux-or-windows-task-automation"><span class="ftwp-text">23. Linux or Windows: Task Automation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#24-process-and-resource-management"><span class="ftwp-text">24. Process and Resource Management</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#25-community-support"><span class="ftwp-text">25. Community Support</span></a></li></ol></li></ol></nav></div>
<div id="ftwp-postcontent"><div id="td_uid_1_5ba91ae8271cc" class="tdc-row"><div class="vc_row td_uid_1_5ba91ae82720c_rand  wpb_row td-pb-row">
<style scoped>

/* custom css */
.td_uid_1_5ba91ae82720c_rand {
                    min-height: 0;
                }
/* inline tdc_css att */

.td_uid_1_5ba91ae82720c_rand{
margin-top:48px !important;
}

.td_uid_1_5ba91ae82720c_rand .td_block_wrap{ text-align:left }

</style><div class="vc_column td_uid_2_5ba91ae8276dd_rand  wpb_column vc_column_container tdc-column td-pb-span12"><div class="wpb_wrapper"><div class="td_block_wrap tdb_breadcrumbs td_uid_3_5ba91ae827ada_rand td-pb-border-top td_block_template_9 tdb-breadcrumbs " data-td-block-uid="td_uid_3_5ba91ae827ada">
<style>

/* inline tdc_css att */

.td_uid_3_5ba91ae827ada_rand{
margin-top:-30px !important;
}

</style>
<style>
/* custom css */
.td_uid_3_5ba91ae827ada_rand .tdb-bread-sep {
                    font-size: 8px;
                }
                
                .td_uid_3_5ba91ae827ada_rand .tdb-bread-sep {
                    margin: 0 5px;
                }
                 
				.td-theme-wrap .td_uid_3_5ba91ae827ada_rand {
					text-align: left;
				}
				
				.td_uid_3_5ba91ae827ada_rand {
					font-family:Open Sans !important;
				}
</style><div class="tdb-block-inner td-fix-index"><span><a title="" class="tdb-entry-crumb" href="https://www.ubuntupit.com/">Home</a></span> <i class="td-icon-right tdb-bread-sep"></i> <span><a title="View all posts in Distros" class="tdb-entry-crumb" href="https://www.ubuntupit.com/category/distros/">Distros</a></span> <i class="td-icon-right tdb-bread-sep"></i> <span><a title="Linux or Windows: 25 Things You Must Know While Choosing The Best Platform" class="tdb-entry-crumb" href="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/">Linux or Windows: 25 Things You Must Know While Choosing The Best...</a></span></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://www.ubuntupit.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.ubuntupit.com/category/distros/",
                                "name": "Distros"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/",
                                "name": "Linux or Windows: 25 Things You Must Know While Choosing The Best..."                                
                            }
                        }    ]
                        }
                       </script><div class="td_block_wrap tdb_single_categories td_uid_4_5ba91ae8284d4_rand td-pb-border-top td_block_template_9 " data-td-block-uid="td_uid_4_5ba91ae8284d4">
<style>

/* inline tdc_css att */

.td_uid_4_5ba91ae8284d4_rand{
margin-bottom:20px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_4_5ba91ae8284d4_rand{
margin-bottom:15px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.td_uid_4_5ba91ae8284d4_rand{
margin-bottom:10px !important;
}
}

</style>
<style>
/* custom css */
.td_uid_4_5ba91ae8284d4_rand .tdb-entry-category {
					padding: 7px 12px 6px;
				}
                
				.td_uid_4_5ba91ae8284d4_rand .tdb-entry-category {
					margin: 0 12px 0 0;
				}
                
				.td_uid_4_5ba91ae8284d4_rand .tdb-cat-bg {
					border-width: 1px;
				}
				
				.td_uid_4_5ba91ae8284d4_rand .tdb-cat-bg,
				.td_uid_4_5ba91ae8284d4_rand .tdb-cat-bg:before {
					border-radius: 50px;
				}
                
				.td_uid_4_5ba91ae8284d4_rand .tdb-cat-sep {
					font-size: 14px;
				}
                
				.td_uid_4_5ba91ae8284d4_rand .tdb-cat-text {
					margin-right: 10px;
				}
				
				.td-theme-wrap .td_uid_4_5ba91ae8284d4_rand {
					text-align: left;
				}
				
				.td_uid_4_5ba91ae8284d4_rand .tdb-entry-category {
					font-family:Poppins !important;font-size:11px !important;line-height:1 !important;font-weight:600 !important;text-transform:uppercase !important;letter-spacing:1px !important;
				}
</style><div class="tdb-category td-fix-index"><a class="tdb-entry-category" href="https://www.ubuntupit.com/category/distros/"><span class="tdb-cat-bg" style="background-color:#1e73be; border-color:#1e73be;"></span>Distros</a><a class="tdb-entry-category" href="https://www.ubuntupit.com/category/featured/"><span class="tdb-cat-bg" style="background-color:#a444bd; border-color:#a444bd;"></span>Featured</a></div></div><div class="td_block_wrap tdb_title td_uid_5_5ba91ae828c22_rand tdb-single-title td-pb-border-top td_block_template_9" data-td-block-uid="td_uid_5_5ba91ae828c22">
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.td_uid_5_5ba91ae828c22_rand{
margin-bottom:5px !important;
}
}

</style>
<style>
/* custom css */
.td_uid_5_5ba91ae828c22_rand .tdb-title-text {
					color: #222222;
				}
				
				.td_uid_5_5ba91ae828c22_rand .tdb-title-line:after  {
					height: 2px;
				}
				
				.td_uid_5_5ba91ae828c22_rand .tdb-title-line  {
					height: 50px;
				}
				
				.td_uid_5_5ba91ae828c22_rand .tdb-title-line:after   {
					bottom: 40%;
				}
				
				.td-theme-wrap .td_uid_5_5ba91ae828c22_rand {
					text-align: left;
				}
				.td_uid_5_5ba91ae828c22_rand .tdb-first-letter {
					left: -0.36em;
					right: auto;
				}
				
				.td_uid_5_5ba91ae828c22_rand .tdb-title-text {
					font-family:Poppins !important;font-size:42px !important;line-height:1.2 !important;font-weight:700 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_5_5ba91ae828c22_rand .tdb-title-text {
					font-family:Poppins !important;font-size:36px !important;line-height:1.2 !important;font-weight:700 !important;
				}
}

/* phone */
@media (max-width: 767px){
.td_uid_5_5ba91ae828c22_rand .tdb-title-text {
					font-family:Poppins !important;font-size:30px !important;line-height:1.2 !important;font-weight:700 !important;
				}
}
</style><div class="tdb-block-inner td-fix-index"><h1 class="tdb-title-text">Linux or Windows: 25 Things You Must Know While Choosing The Best Platform</h1><div></div><div class="tdb-title-line"></div></div></div><div class="vc_row_inner td_uid_7_5ba91ae8293bf_rand  vc_row vc_inner wpb_row td-pb-row">
<style scoped>

/* custom css */
@media (min-width: 768px) {
	                .td_uid_7_5ba91ae8293bf_rand {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .td_uid_7_5ba91ae8293bf_rand .vc_column_inner {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }

                
                .td_uid_7_5ba91ae8293bf_rand {
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }
/* inline tdc_css att */

.td_uid_7_5ba91ae8293bf_rand{
margin-right:150px !important;
margin-bottom:11px !important;
margin-left:150px !important;
padding-top:1px !important;
padding-bottom:1px !important;
border-color:#eaeaea !important;
border-style:solid !important;
border-width: 1px 0px 1px 0px !important;
}

.td_uid_7_5ba91ae8293bf_rand .td_block_wrap{ text-align:left }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_7_5ba91ae8293bf_rand{
margin-right:0px !important;
margin-bottom:30px !important;
margin-left:0px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.td_uid_7_5ba91ae8293bf_rand{
margin-right:0px !important;
margin-bottom:30px !important;
margin-left:0px !important;
padding-top:5px !important;
padding-bottom:5px !important;
}
}

</style><div class="vc_column_inner td_uid_8_5ba91ae82960d_rand  wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>

/* inline tdc_css att */

.td_uid_8_5ba91ae82960d_rand{
margin-bottom:0px !important;
}

/* phone */
@media (max-width: 767px)
{
.td_uid_8_5ba91ae82960d_rand{
width:45% !important;
display:inline-block !important;
}
}

</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_author td_uid_9_5ba91ae829807_rand td-pb-border-top td_block_template_9 tdb-post-meta" data-td-block-uid="td_uid_9_5ba91ae829807">
<style>

/* inline tdc_css att */

.td_uid_9_5ba91ae829807_rand{
margin-bottom:0px !important;
}

</style>
<style>
/* custom css */
.td_uid_9_5ba91ae829807_rand {
                    display: inline-block;
                }

                
                .td_uid_9_5ba91ae829807_rand .avatar {
                    width: 30px;
                    height: 30px;
                }
                
                .td_uid_9_5ba91ae829807_rand .avatar {
                    margin-right: 6px;
                }
                
                .td_uid_9_5ba91ae829807_rand .avatar {
                    border-radius: 50%;
                }
                

                
				.td_uid_9_5ba91ae829807_rand .tdb-author-name {
					color: #000;
				}
                
				.td_uid_9_5ba91ae829807_rand .tdb-author-name {
					font-family:Poppins !important;font-size:12px !important;text-transform:uppercase !important;
				}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-author-photo" href="https://www.ubuntupit.com/author/mehedi-hasan/"><img alt='' src='https://secure.gravatar.com/avatar/97511e656e2014d4868642e238f17da3?s=96&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/97511e656e2014d4868642e238f17da3?s=192&#038;d=retro&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></a><span class="tdb-author-by"></span> <a class="tdb-author-name" href="https://www.ubuntupit.com/author/mehedi-hasan/">Mehedi Hasan</a></div></div></div></div></div><div class="vc_column_inner td_uid_10_5ba91ae829de9_rand  wpb_column vc_column_container tdc-inner-column td-pb-span6">
<style scoped>

/* inline tdc_css att */

.td_uid_10_5ba91ae829de9_rand{
margin-bottom:0px !important;
padding-left:10px !important;
border-color:#eaeaea !important;
border-style:solid !important;
border-width: 0px 0px 0px 1px !important;
}

/* phone */
@media (max-width: 767px)
{
.td_uid_10_5ba91ae829de9_rand{
width:55% !important;
display:inline-block !important;
}
}

</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_comments_count td_uid_11_5ba91ae82a014_rand td-pb-border-top td_block_template_9 tdb-post-meta" data-td-block-uid="td_uid_11_5ba91ae82a014">
<style>

/* inline tdc_css att */

.td_uid_11_5ba91ae82a014_rand{
margin-right:15px !important;
margin-bottom:0px !important;
}

/* phone */
@media (max-width: 767px)
{
.td_uid_11_5ba91ae82a014_rand{
margin-right:0px !important;
}
}

</style>
<style>
/* custom css */
.td_uid_11_5ba91ae82a014_rand {
                    float: right;
                }
                
                .td_uid_11_5ba91ae82a014_rand {
                    display: inline-block;
                }                
                
                .td_uid_11_5ba91ae82a014_rand i {
                    font-size: 12px;
                }
                
                .td_uid_11_5ba91ae82a014_rand i {
                    margin-right: 8px;
                }
                
				.td_uid_11_5ba91ae82a014_rand a {
					color: #444;
				}
                
				.td_uid_11_5ba91ae82a014_rand {
					font-family:Poppins !important;font-size:12px !important;font-weight:500 !important;
				}
</style><div class="tdb-block-inner td-fix-index"><a href="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/#comments"><i class="td-icon-comments"></i><span class="tdb-add-text"></span><span>39</span></a></div></div><div class="td_block_wrap tdb_single_post_views td_uid_12_5ba91ae82a45a_rand td-pb-border-top td_block_template_9 tdb-post-meta" data-td-block-uid="td_uid_12_5ba91ae82a45a">
<style>

/* inline tdc_css att */

.td_uid_12_5ba91ae82a45a_rand{
margin-right:100px !important;
margin-bottom:0px !important;
}

</style>
<style>
/* custom css */
.td_uid_12_5ba91ae82a45a_rand i {
                    font-size: 14px;
                }
                
                .td_uid_12_5ba91ae82a45a_rand i {
                    margin-right: 5px;
                }
</style><div class="tdb-block-inner td-fix-index"><i class="td-icon-views"></i><span class="tdb-add-text"></span><span class="td-nr-views-5992">3218</span></div></div></div></div></div></div><div class="td_block_wrap tdb_single_content td_uid_13_5ba91ae82a819_rand td-pb-border-top td_block_template_9 td-post-content" data-td-block-uid="td_uid_13_5ba91ae82a819">
<style>

/* inline tdc_css att */

.td_uid_13_5ba91ae82a819_rand{
margin-right:170px !important;
margin-left:170px !important;
}

/* phone */
@media (max-width: 767px)
{
.td_uid_13_5ba91ae82a819_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_13_5ba91ae82a819_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

</style>
<style>
/* custom css */
.td_uid_13_5ba91ae82a819_rand,
                .td_uid_13_5ba91ae82a819_rand p {
			        font-family:Open Sans !important;
		        }
				
				.td_uid_13_5ba91ae82a819_rand h1 {
			        font-family:Poppins !important;
		        }
				
				.td_uid_13_5ba91ae82a819_rand h2 {
			        font-family:Poppins !important;
		        }
				
				.td_uid_13_5ba91ae82a819_rand h3 {
			        font-family:Poppins !important;
		        }
				
				.td_uid_13_5ba91ae82a819_rand li {
			        font-family:Open Sans !important;
		        }
				
				.td_uid_13_5ba91ae82a819_rand blockquote p {
			        font-family:Poppins !important;font-size:18px !important;
		        }
</style><div class="tdb-block-inner td-fix-index"><div id="ftwp-container" class="ftwp-wrap ftwp-hidden-state ftwp-minimize ftwp-top-right"><button type="button" id="ftwp-trigger" class="ftwp-shape-round ftwp-border-bold" title="click To Maximize The Table Of Contents"><span class="ftwp-trigger-icon ftwp-icon-menu"></span></button><nav id="ftwp-contents" class="ftwp-shape-square ftwp-border-bold"><header id="ftwp-header"><span id="ftwp-header-control" class="ftwp-icon-menu"></span><button type="button" id="ftwp-header-minimize"></button><h3 id="ftwp-header-title">CONTENTS</h3></header><ol id="ftwp-list" class="ftwp-liststyle-none ftwp-effect-bounce-to-right ftwp-list-nest ftwp-strong-first"><li class="ftwp-item ftwp-has-sub"><a class="ftwp-anchor" href="#linux-or-windows-which-one-is-the-best-platform"><span class="ftwp-text">Linux or Windows: Which One is the Best Platform?</span></a><ol class="ftwp-sub"><li class="ftwp-item"><a class="ftwp-anchor" href="#1-linux-or-windows-basic-foundation"><span class="ftwp-text">1. Linux or Windows: Basic Foundation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#2-system-stability"><span class="ftwp-text">2. System Stability</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#3-hardware-support"><span class="ftwp-text">3. Hardware Support</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#4-linux-or-windows-targeted-user-group"><span class="ftwp-text">4. Linux or Windows: Targeted User Group</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#5-f-o-s-s-vs-proprietary"><span class="ftwp-text">5. F.O.S.S vs. Proprietary</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#6-linux-vs-windows-security-and-privacy"><span class="ftwp-text">6. Linux vs Windows Security and Privacy</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#7-antivirus-and-malware-threat"><span class="ftwp-text">7. Antivirus and Malware Threat</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#8-linux-or-windows-customization"><span class="ftwp-text">8. Linux or Windows: Customization</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#9-administrative-privilege-and-root-access"><span class="ftwp-text">9. Administrative Privilege and Root Access</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#10-programming-platform-for-developers"><span class="ftwp-text">10. Programming Platform for Developers</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#11-install-update-and-upgrade"><span class="ftwp-text">11. Install, Update and Upgrade</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#12-different-flavors-for-different-need"><span class="ftwp-text">12. Different Flavors for Different Need</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#13-linux-or-windows-gaming-area"><span class="ftwp-text">13. Linux or Windows: Gaming Area</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#14-software-availability-and-compatibility"><span class="ftwp-text">14. Software Availability and Compatibility</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#15-photoshop-alternative"><span class="ftwp-text">15. Photoshop Alternative</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#16-alternative-to-office-suite"><span class="ftwp-text">16. Alternative To Office Suite</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#17-multimedia-editor"><span class="ftwp-text">17. Multimedia Editor</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#18-support-of-windows-software-via-wine-or-playonlinux"><span class="ftwp-text">18. Support of Windows Software via Wine or PlayOnLinux</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#19-software-management-system"><span class="ftwp-text">19. Software Management System</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#20-linux-server-or-windows-server"><span class="ftwp-text">20. Linux Server or Windows Server</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#21-blue-screen-and-de-fragmentation"><span class="ftwp-text">21. Blue Screen and De-fragmentation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#22-file-extension-to-run-the-file"><span class="ftwp-text">22. File Extension To “run” The File</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#23-linux-or-windows-task-automation"><span class="ftwp-text">23. Linux or Windows: Task Automation</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#24-process-and-resource-management"><span class="ftwp-text">24. Process and Resource Management</span></a></li><li class="ftwp-item"><a class="ftwp-anchor" href="#25-community-support"><span class="ftwp-text">25. Community Support</span></a></li></ol></li></ol></nav></div>
<div id="ftwp-postcontent"><p>Choosing the best platform &#8211; Linux or Windows is complicated. Because both the system is versatile and capable of doing many mission-oriented and regular task. So if I ask you which one is the best system between Linux and Windows? On this topic, you can start an ever ending discussion. Windows OS is the most used operating system in the desktop world, no doubt in this statement, but “most used” can’t prove itself to be the best option in a bigger prospect.</p>

<div class="quads-location quads-ad4" id="quads-ad4" style="float:none;margin:3px 0 3px 0;text-align:center;">

<script async data-cfasync="false" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" data-cfasync="false">
var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script>

</div>
<p>We all know that cigarette is one of the &#8220;most used&#8221; consumer product in the world but still, it’s not good for health. It’s challenging to leave smoking because people are habituated with this addiction. So why I have given this example which is entirely off topic? Because we all know, humanity is a slave of habit, and accordingly, most of the users are quite habituated with the use of a Windows system for quite a long time. Now they can’t leave it just like smoking. If a bird remains in a case, how will it enjoy freedom? Even one day the bird will forget, he can fly.</p>
<h2 id="linux-or-windows-which-one-is-the-best-platform" class="ftwp-heading"><b>Linux or Windows: Which One is the Best Platform?</b></h2>
<hr />
<p>Linux has thousand of overriding factors that can prove; it’s the best platform than the Windows system. Here, I want to clear one thing that Linux is a kernel, and with the compilation of many essential software and drivers, it makes a distro.</p>
<p>There are hundreds of Linux distributions available in the market which itself stands apart from the crowd and capable to compete with Windows OS or MacOS. In this article, I will tell you some of the best things to know when you go for choosing the best OS platform between Linux or Windows. So sit tight and get known all the facts and findings that are going to unchain you and let you feel the freedom.</p>
<h3 id="1-linux-or-windows-basic-foundation" class="ftwp-heading"><strong>1. Linux or Windows: Basic Foundation</strong></h3>
<hr />
<p>Linux follows a distinguishing trait; its un-unified development process. No single entity has a complete grip on Linux. The Linux kernel, the base of the operating system, is developed and maintained by Linux Foundation where lots of community volunteer around the world are involved and make their best contribution. Linux distros are what we usually see as Linux OS. Around the world, many company and volunteers have created these Linux distros with compiling desktop environments, software, hardware drivers with the core Kernel.</p>
<p>Each Linux distribution has its development cycle, which is not related to the kernel development. Moreover, there are also many organizations and community enthusiasts who have created the desktop environment and window managers. Linux kernel and distros became popular, widely used and adored by the mass people because of the support and contribution from its vast community.</p>
<p>Now let me say something about the Windows system. There is only one company &#8211; Microsoft, who is doing all the development and maintenance for the whole OS; kernel, desktop environment, and much of the pre-installed software. You have to accept whatever they offer you; whether it&#8217;s useful or not.</p>
<h3 id="2-system-stability" class="ftwp-heading"><strong>2. System Stability</strong></h3>
<hr />
<p>Windows system is not a lightweight or speedy instead tends to get sluggish over the time. You may feel your system outdated if not adequately maintained. Linux system is much quicker and doesn&#8217;t demand lots of resources. It can run on age-old hardware and modern high-end machines as well.</p>
<p><figure id="attachment_5996" style="width: 640px" class="wp-caption aligncenter"><img class="size-full wp-image-5996" src="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-System-Stability.jpg" alt="Linux or Windows: System Stability" width="640" height="427" srcset="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-System-Stability.jpg 640w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-System-Stability-300x200.jpg 300w" sizes="(max-width: 640px) 100vw, 640px" /><figcaption class="wp-caption-text">Linux or Windows: System Stability</figcaption></figure></p>
<p>Many distros come with bare bone elements for ensuring the best performances for the ultimate users. If you install a Linux distro and run it for a long time without any update or upgrade, you will not face a single problem, and yet you find the system as new as it was.</p>

<div class="quads-location quads-ad1" id="quads-ad1" style="float:none;margin:3px 0 3px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="fluid" data-ad-layout-key="-4z+ca-h-e5+t3" data-ad-client="ca-pub-4812623990144566" data-ad-slot="8760064068"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h3 id="3-hardware-support" class="ftwp-heading"><strong>3. Hardware Support</strong></h3>
<hr />
<p>Windows OS demands high configuration for optimal performance. But if you have an age-old desktop or laptop with lower-end hardware, then I strongly suggest you use <a href="https://www.ubuntupit.com/top-5-best-lightweight-linux-distros-boost-old-computer/" rel="noopener">lightweight Linux distro</a> like Lubuntu or <a title="Everything You Need To Know About Peppermint Linux OS 9" href="https://www.ubuntupit.com/everything-you-need-to-know-about-peppermint-linux-os/">Peppermint OS</a> for giving it a second life. You can use that older machine as a <a href="https://www.ubuntupit.com/13-best-linux-media-server-software-for-making-your-own-home-theater-pc/" rel="noopener">media server</a> or <a href="https://www.ubuntupit.com/best-linux-ftp-client-top-10-reviewed-for-linux-geeks/" rel="noopener">FTP server</a>.</p>
<p>Linux Kernel comes with full-fledged driver solution inbuilt for the age-old machine. But in the case of a Windows system, you will face driver and software compatibility issue, system freezing issue, hardware related drivers problem, etc. Moreover, Linux is also fully compatible with the most recent devices ensuring the highest <a href="https://www.ubuntupit.com/how-to-speed-up-ubuntu-linux-must-follow-tips/" rel="noopener">performance</a>.</p>
<h3 id="4-linux-or-windows-targeted-user-group" class="ftwp-heading"><b>4. Linux or Windows: Targeted User Group</b></h3>
<hr />
<p>Windows OS is commonly said as the best OS for the novice users, but Linux can be suitable for both beginners and advanced users. Windows is user-friendly because, from your childhood, you have only seen it in your home, school or friends computer; you never saw a Linux system in around.</p>
<p><figure id="attachment_6000" style="width: 700px" class="wp-caption aligncenter"><img class="size-full wp-image-6000" src="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Targeted-User-Group.jpg" alt="Linux or Windows: Targeted User Group" width="700" height="343" srcset="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Targeted-User-Group.jpg 700w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Targeted-User-Group-300x147.jpg 300w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Targeted-User-Group-324x160.jpg 324w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption class="wp-caption-text">Linux or Windows or Mac: Targeted User Group</figcaption></figure></p>
<p>So it was difficult for you to understand that there were many other far better options available on the other side of the coin. I suggest you use a Linux distro like <a title="Linux Mint vs Ubuntu: 15 Facts To Know Before Choosing The Best One" href="https://www.ubuntupit.com/linux-mint-vs-ubuntu-15-facts-to-know-before-choosing-the-best-one/">Ubuntu or Linux Mint</a>, and I bet, you will never look back again to get either Windows OS or MacOS.</p>
<h3 id="5-f-o-s-s-vs-proprietary" class="ftwp-heading"><strong>5. F.O.S.S vs. Proprietary</strong></h3>
<hr />
<p>The motto of Linux is to let you feel the freedom of getting free and <a title="Best Linux Software: Our Editorial List of Essential Linux Apps" href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/">open source software</a>. On the other hand, most of the software used in Windows and MacOS are paid or proprietary in nature. There is also some freeware software available for Windows OS, but eventually, it will cost you the penny when you need the essential tools or features on that specific application.</p>
<p><figure id="attachment_5999" style="width: 600px" class="wp-caption aligncenter"><img class="size-full wp-image-5999" src="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-F.O.S.S-vs.-Proprietary.jpg" alt="Linux or Windows: F.O.S.S vs. Proprietary" width="600" height="366" srcset="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-F.O.S.S-vs.-Proprietary.jpg 600w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-F.O.S.S-vs.-Proprietary-300x183.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption class="wp-caption-text">Linux or Windows or Mac: F.O.S.S vs. Proprietary</figcaption></figure></p>
<h3 id="6-linux-vs-windows-security-and-privacy" class="ftwp-heading"><strong>6. Linux vs Windows Security and Privacy</strong></h3>
<hr />
<p>Security and personal privacy are the cornerstone factors for the Linux OS. That&#8217;s why it has enormous popularity among the IT professionals. Linux system doesn&#8217;t provide root access or administrative privilege to the users by default. This is why the threats can&#8217;t hit the core of Linux system except for some file and folders. But in Windows system, malware and viruses get access to the system files easily and can damage in large scale.</p>
<p>Linux kernel is open source thus it&#8217;s more secure and well maintained due to the involvement of a large community who scans the flaws regularly. Moreover, maximum viruses or threats are being created for Windows system keeping in mind. That&#8217;s why you need a <a href="https://www.ubuntupit.com/best-linux-antivirus-top-10-reviewed-compared/" rel="noopener">good antivirus</a> for Windows OS just at the beginning. Linux is not also immune from the threats, but if you follow the best practices, you probably will be safe than Windows system.</p>
<p>In a container of Windows OS, your every steps and footprint are traced and recorded. Microsoft does keep all the personal information, and we don&#8217;t know with whom, it shares the information. On the other hand, it&#8217;s quite impossible to make any backdoor in Linux kernel.</p>

<div class="quads-location quads-ad7" id="quads-ad7" style="float:none;margin:3px 0 3px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4812623990144566" data-ad-slot="1685524836" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h3 id="7-antivirus-and-malware-threat" class="ftwp-heading"><b>7. Antivirus and Malware Threat</b></h3>
<hr />
<p>Windows OS is the best home for viruses and malware threats. I believe you know it. After completing Windows installation, I know you go searching for a <a href="https://www.ubuntupit.com/best-linux-antivirus-top-10-reviewed-compared/" rel="noopener">good antivirus</a> to protect the system. But in the case of Linux, you hardly need to think about it. Linux security and malware protection are hardened to some extent &#8220;fresh-out-of-the-box.&#8221;</p>
<p><figure id="attachment_5997" style="width: 700px" class="wp-caption aligncenter"><img class="size-full wp-image-5997" src="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Antivirus-and-Malware-Threat.jpg" alt="Linux or Windows: Antivirus and Malware Threat" width="700" height="438" srcset="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Antivirus-and-Malware-Threat.jpg 700w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Antivirus-and-Malware-Threat-300x188.jpg 300w" sizes="(max-width: 700px) 100vw, 700px" /><figcaption class="wp-caption-text">Linux or Windows: Antivirus and Malware Threat</figcaption></figure></p>
<p>But you know; the threat is a threat, it may come anywhere anytime. Linux has a huge community to help you out. Whenever any malware or threats go into the Linux system, the community will provide you with a security patch to remove it within no time.</p>
<h3 id="8-linux-or-windows-customization" class="ftwp-heading"><strong>8. Linux or Windows: Customization</strong></h3>
<hr />
<p>Linux is much more customizable than Windows OS. In Windows system, everything comes pre-configured and as closed source. There is hardly anything that you can change as per your needs. There is a command shell &#8220;cmd,&#8221; still it&#8217;s not useful to make any root level changes. Now a day, the things are changing a bit with the tools of &#8220;PowerShell.&#8221; But that&#8217;s not enough to attract the developers&#8217; community.</p>
<p><figure id="attachment_5998" style="width: 543px" class="wp-caption aligncenter"><img class="size-full wp-image-5998" src="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Customization.jpg" alt="Linux or Windows: Customization" width="543" height="395" srcset="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Customization.jpg 543w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Customization-300x218.jpg 300w" sizes="(max-width: 543px) 100vw, 543px" /><figcaption class="wp-caption-text">Linux or Windows: Customization</figcaption></figure></p>
<p>On the other hand, you can change every bit of the Linux system as per your requirements. The Linux kernel itself and all the software used in Linux comes as open source, and users can do any modification under specific rules. Linux CLI environment is too robust to perform root level task. Moreover, you can change overall look and feel of your Linux distros via distro specific tweak tools.</p>
<h3 id="9-administrative-privilege-and-root-access" class="ftwp-heading"><strong>9. Administrative Privilege and Root Access</strong></h3>
<hr />
<p>Linux provides root-level administrative access through command line interface where users can perform mission-oriented task effortlessly. With the help of root access, you can change every bit of things in the Linux ecosystem. But in Windows system, everything is pre-set by Microsoft. You hardly have any administrative privileges to perform root level task.</p>
<h3 id="10-programming-platform-for-developers" class="ftwp-heading"><b>10. Programming Platform for Developers</b></h3>
<hr />
<p>If you are a programmer or intend to do programming, then I highly suggest you use Linux instead of Windows OS. You will find lots of programming language or <a title="Best Linux Code Editor: Top 10 Reviewed and Compared" href="https://www.ubuntupit.com/best-linux-code-editor-top-10-reviewed-compared/">IDEs</a> here. All those developers tools are made keep in mind of the Linux environment first. Hence they work efficiently and smoothly on <a title="Best 5 Linux Distros for Developers and Programmers" href="https://www.ubuntupit.com/best-5-linux-distros-for-developers-programmers/">Linux platform</a>.</p>
<h3 id="11-install-update-and-upgrade" class="ftwp-heading"><strong>11. Install, Update and Upgrade</strong></h3>
<hr />
<p>It&#8217;s easy and effortless to <a title="How to Install, Update &amp; Upgrade Ubuntu: An Easy Tutorial for Newbie" href="https://www.ubuntupit.com/install-update-upgrade-ubuntu-easy-tutorial-newbie/">install and update systems</a> or any third party <a title="Best Linux Software: Our Editorial List of Essential Linux Apps" href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/">software in Linux</a>. All the software and system update files are included in a centralized repository which makes it safe and more accessible to update the system and software as well.</p>
<p>But in a Windows system, it&#8217;s hell difficult and time-consuming to update the system and third-party applications. Windows don&#8217;t only pull the updates from Microsoft site, but also it takes every software updates from app-specific software protocol.</p>

<div class="quads-location quads-ad2" id="quads-ad2" style="float:none;margin:3px 0 3px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-4812623990144566" data-ad-slot="9115914332"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h3 id="12-different-flavors-for-different-need" class="ftwp-heading"><strong>12. Different Flavors for Different Need</strong></h3>
<hr />
<p>Linux is more capable than Windows OS in this sector. There are hundreds of Linux distros basing on different needs and <a href="https://www.ubuntupit.com/best-linux-desktop-environment-reviewed-and-compared/" rel="noopener">various desktop flavors</a>. If you are a Windows users, then Linux has <a href="https://www.ubuntupit.com/everything-you-need-to-know-about-linux-zorin-os/" rel="noopener">Zorin OS</a> or <a href="https://www.ubuntupit.com/best-things-to-do-after-installing-linux-mint/" rel="noopener">Linux Mint</a> for you to make a smooth transition of the previous continuation.</p>
<p>And If you are a MacOS user, then Linux also covers you as well with <a href="https://www.ubuntupit.com/best-things-to-do-after-installing-ubuntu/" rel="noopener">Ubuntu</a> or <a href="https://www.ubuntupit.com/top-10-best-things-installing-elementary-os/" rel="noopener">Elementary OS</a>. Or you can even use one specific Linux distro with some Linux desktop environments in a choice. Moreover, there are some task-specific Linux distros available out there like Kali Linux for penetration testing or hacking.</p>
<h3 id="13-linux-or-windows-gaming-area" class="ftwp-heading"><b>13. Linux or Windows: Gaming Area</b></h3>
<hr />
<p>Yes, I confess that there was a time when Linux was not a good choice as a <a title="Best Linux Gaming Distros: 5 Shortlisted Recommendation" href="https://www.ubuntupit.com/best-linux-gaming-distros-5-shortlisted-recommendation/">gaming platform</a>. Game developers were not interested in developing their games for this platform. But now the time has changed. Most of the latest and trending games, you will find it for Linux. Now you can play all the best <a title="Top 15 Best Free Linux Games That Everyone Should Play" href="https://www.ubuntupit.com/top-15-best-free-linux-games-everyone-play/">Linux games</a> or <a title="Best Free Steam Games: Top 12 Games Reviewed" href="https://www.ubuntupit.com/best-free-steam-games-top-12-games-reviewed/">Steam games</a> both offline and online. Moreover, it’s effortless to <a title="How to Play Games on Linux: An Easy Tutorial for Newbie Users" href="https://www.ubuntupit.com/play-games-on-linux-easy-tutorial-newbie-users/">play games on Linux</a> and about the gaming experience! You let me know in the comment section.</p>
<h3 id="14-software-availability-and-compatibility" class="ftwp-heading"><strong>14. Software Availability and Compatibility</strong></h3>
<hr />
<p>If you ask me about the software availability and compatibility in Linux ecosystem, I bet you that Linux wins the crown. Linux covers all the sectors including personal software, <a title="Top 10 Best Linux Video Players: Enjoy Ultimate Movie and Music" href="https://www.ubuntupit.com/top-10-best-linux-video-players-enjoy-ultimate-movie-music/">media software</a>, business suites, <a title="Top 10 Linux Photoshop Alternative Photo Management Software" href="https://www.ubuntupit.com/top-10-linux-photoshop-alternative-photo-management-software/">design materials</a>, server tools, productivity applications, programming and app development software, and what&#8217;s not. You can check a detailed editorial list on <a href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/" rel="noopener">Best Linux Software</a>.</p>
<h3 id="15-photoshop-alternative" class="ftwp-heading"><strong>15. Photoshop Alternative</strong></h3>
<hr />
<p>Image editing software Photoshop is one of the vital elements that don&#8217;t let the users adopt any other OS except Windows. Photoshop doesn&#8217;t support Linux. But you get a lot of good <a href="https://www.ubuntupit.com/top-10-linux-photoshop-alternative-photo-management-software/" rel="noopener">alternative to Adobe Photoshop</a> in Linux distros including <a href="https://www.ubuntupit.com/gimp-photo-editor-best-image-editing-software-for-linux/" rel="noopener">GIMP</a>, <a href="https://www.ubuntupit.com/darktable-an-open-source-photography-application-for-ubuntu/" rel="noopener">Darktable</a>, <a href="https://www.ubuntupit.com/krita-an-open-source-digital-painting-software-for-ubuntu-linux/" rel="noopener">Krita</a>, etc.</p>
<p><strong>Read More: <a href="https://www.ubuntupit.com/top-10-linux-photoshop-alternative-photo-management-software/" rel="noopener">Top 10 Linux Photoshop Alternative Photo Management Software</a></strong></p>
<h3 id="16-alternative-to-office-suite" class="ftwp-heading"><strong>16. Alternative To Office Suite</strong></h3>
<hr />
<p>Like Photoshop, MS office suite is also such an outstanding software that also keeps the appeal to use Windows OS. A lot of users and organizations depends on these sort of <a href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/" rel="noopener">productivity software</a>. In the Linux world, there are many better options available to the <a href="https://www.ubuntupit.com/top-10-best-free-office-suite-software-as-ms-office-alternative-for-linux/" rel="noopener">MS office suite</a>. <a href="https://www.ubuntupit.com/libreoffice-suite-best-alternative-to-microsoft-office-suite-for-linux/" rel="noopener">LibreOffice</a> is one of them which can give a good fight to Microsoft Office suite.</p>
<p><strong>Read More: <a href="https://www.ubuntupit.com/top-10-best-free-office-suite-software-as-ms-office-alternative-for-linux/" rel="noopener">Top 10 Best Free Office Suite Software as MS Office Alternative for Linux</a></strong></p>
<h3 id="17-multimedia-editor" class="ftwp-heading"><strong>17. Multimedia Editor</strong></h3>
<hr />
<p>If you are getting lots of options for editing multimedia files in Windows system, Linux is also providing the same amount of choice and sometimes even more. Here you can check by yourself a list of <a href="https://www.ubuntupit.com/top-10-best-video-editing-software-ubuntu-install/" rel="noopener">Best Video Editing Software for Linux</a>.</p>
<h3 id="18-support-of-windows-software-via-wine-or-playonlinux" class="ftwp-heading"><strong>18. Support of Windows Software via Wine or PlayOnLinux</strong></h3>
<hr />
<p>As I have said earlier that there are lots of choices of each Windows software in Linux but still if you want to use some custom made Windows app or any app in Linux; there is a way out to do that tricks. Wine and PlayOnLinux are there for you to perform this Windows hack. With the help of this two <a href="https://www.ubuntupit.com/best-linux-software-our-editorial-list-of-essential-linux-apps/" rel="noopener">Linux software</a>, you can run many essential Windows software in Linux. Moreover, you can also play some Windows OS specific <a href="https://www.ubuntupit.com/play-games-on-linux-easy-tutorial-newbie-users/" rel="noopener">games on Linux</a> via PlayOnLinux.</p>

<div class="quads-location quads-ad7" id="quads-ad7" style="float:none;margin:3px 0 3px 0;text-align:center;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4812623990144566" data-ad-slot="1685524836" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h3 id="19-software-management-system" class="ftwp-heading"><strong>19. Software Management System</strong></h3>
<hr />
<p>Software management system is an essential element for any OS. System stability and flexibility depend on software management. In this regard, Windows OS remains far behind than Linux system. In Windows OS, you have to go to the software specific site for getting the installer file for downloading and installing that software. This file may be tempered or includes many adware, malware, adverts, etc.; you may not know it. That&#8217;s time-consuming and not safe if the vendor is not authenticated one.</p>
<p>On the other hand, Linux distros provide a centralized software center for installing any applications. This software is thoroughly checked by the community, and there is hardly any possibility to include any adware, malware, adverts, etc. Moreover, there are lots of ways to <a href="https://www.ubuntupit.com/how-to-install-software-in-ubuntu-linux-a-complete-guide-for-newbie/" rel="noopener">install software in Linux</a> system. If one process doesn&#8217;t work or you are not comfortable with command line tools; anytime you can use another one.</p>
<p><strong>Read More: <a href="https://www.ubuntupit.com/how-to-install-software-in-ubuntu-linux-a-complete-guide-for-newbie/" rel="noopener">How To Install Software in Ubuntu Linux: A Complete Guide for Newbie</a></strong></p>
<h3 id="20-linux-server-or-windows-server" class="ftwp-heading"><strong>20. Linux Server or Windows Server</strong></h3>
<hr />
<p>If you consider about server security, stability, freedom of choices, hardware compatibility and cost-effectiveness, then Linux server beats the Windows-based server in every way. Windows is a popular option for desktop usages (novice think so), and Linux is the best option for server mode system.</p>
<p><a href="https://www.ubuntupit.com/best-linux-server-distro-top-10-compared-recommendation/" rel="noopener">Linux server</a> system offers a lot of customization options with a wide range of effective monitoring and analyzing tools. Linux server is less more vulnerable than Windows server regarding malware and online threats. It&#8217;s quite impossible to create any backdoor in Linux kernel whereas Windows system is sensitive to that situation.</p>
<h3 id="21-blue-screen-and-de-fragmentation" class="ftwp-heading"><b>21. Blue Screen and De-fragmentation</b></h3>
<hr />
<p>Blue screen with fsck running and disk defragmentation are known issues that you may get in your Windows OS. But in the Linux distros, you may get hardly any problem like this one. Linux system handles all the file layouts or file system efficiently, and most of the time, you don’t even require to run de-fragmentation at all.</p>
<p><figure id="attachment_5995" style="width: 593px" class="wp-caption aligncenter"><img class="size-full wp-image-5995" src="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Blue-Screen.jpg" alt="Linux or Windows - Blue Screen" width="593" height="407" srcset="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Blue-Screen.jpg 593w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Blue-Screen-300x206.jpg 300w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Blue-Screen-218x150.jpg 218w, https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-Blue-Screen-436x300.jpg 436w" sizes="(max-width: 593px) 100vw, 593px" /><figcaption class="wp-caption-text">Linux or Windows &#8211; Blue Screen</figcaption></figure></p>
<h3 id="22-file-extension-to-run-the-file" class="ftwp-heading"><strong>22. File Extension To “run” The File</strong></h3>
<hr />
<p>Windows or DOS rely on the file extension to run any file type. But Linux doesn&#8217;t depend on that process. You can give a file any name, and it will not have any effect on the type of file it is. Linux uses a filesystem called “execute bit.” Whenever A user tries to run a file, the Linux process system looks at the file header information for more pieces of information on how to run it instead on the file extension like Windows.</p>
<h3 id="23-linux-or-windows-task-automation" class="ftwp-heading"><strong>23. Linux or Windows: Task Automation</strong></h3>
<hr />
<p>In the Linux system, there are many tools and command cheat sheet to make your task as automatic as it can&#8217;t be on Windows. That&#8217;s why many servers or IT expert prefer to use Linux over Windows to automate their routine system-side task.</p>
<h3 id="24-process-and-resource-management" class="ftwp-heading"><strong>24. Process and Resource Management</strong></h3>
<hr />
<p>In Linux, the software process management is much powerful and effective. With the help of a simple command, you can kill or abort any software to run into the background if it causes any problem. But in Windows, it&#8217;s easy to run a task manager but not sufficient as Linux because the Windows task manager can&#8217;t always kill or stop the problematic software running in the backend.</p>

<div class="quads-location quads-ad4" id="quads-ad4" style="float:none;margin:3px 0 3px 0;text-align:center;">

<script async data-cfasync="false" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type="text/javascript" data-cfasync="false">
var quads_screen_width = document.body.clientWidth;
if ( quads_screen_width >= 1140 ) {
/* desktop monitors */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 1024  && quads_screen_width < 1140 ) {
/* tablet landscape */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width >= 768  && quads_screen_width < 1024 ) {
/* tablet portrait */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}if ( quads_screen_width < 768 ) {
/* phone */
document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px;" data-ad-client="pub-4812623990144566" data-ad-slot="8813676332" ></ins>');
(adsbygoogle = window.adsbygoogle || []).push({});
}</script>

</div>
<p>Linux manages its resources effectively than a Windows system. When software is installed in Linux, it downloads all the required dependencies. Next time, you go for installing any other software, it doesn&#8217;t again download the dependencies if that matches the previous one.</p>
<p>This how Linux keeps the software interlinked, cleaned and lightweight but on the other hand, Windows download each dependency related with an individual software and doesn&#8217;t cross-check with other similar dependencies on the system. That makes the file system heavy and unmanageable sometimes.</p>
<h3 id="25-community-support" class="ftwp-heading"><strong>25. Community Support</strong></h3>
<hr />
<p>As Linux is an outcome of dedicated and passionate community fans. Thus it has a considerable volume of information and documentation that covers everything about Linux. Moreover, there are distro specific tutorials, tips, tweaks and forums from developers and enthusiasts to help you out if any problem faced.</p>
<p>In regards Windows OS, Microsoft is the only vendor to provide documentation for the users which sometimes you may feel lost to find the exact information. Like Linux, Windows system also has a huge fanbase who provides tweaks, tutorials, and tips to solve or customize the system a bit.</p>
<p><strong>Final Thought</strong></p>
<hr />
<p><a href="https://en.wikipedia.org/wiki/Linux" rel="nofollow noopener">Linux</a> has come a long way. There was a saying that Linux is not user-friendly, doesn&#8217;t offer much software choices, need expert-level knowledge, the user interface is not beautiful, not easy to use, etc. But all those things mentioned above are now void. Linux is now user-friendly, offers an intuitive and easy to use interface and provides a centralized software management system with hundreds of different choices. I want to share a joke with you; <em>&#8220;What are air-conditioning and computers have in common ???!!! <b>They are both useless when you open Windows.&#8221;</b></em></p>
<p>Did you like this comparison article on Linux or <a href="https://en.wikipedia.org/wiki/Microsoft_Windows" rel="nofollow noopener">Windows OS</a>? If so, then please do me a favor by sharing it on your social media. And don&#8217;t forget to share your Linux distros experience with us in the comment section.</p>
</div>
</div></div><div class="tdm_block td_block_wrap tdn_block_newsletter_subscribe td_uid_14_5ba91ae82eb7c_rand tds_newsletter7_block tdn-content-horiz-center td-pb-border-top td_block_template_9  td-fix-index" data-td-block-uid="td_uid_14_5ba91ae82eb7c">
<style>

/* inline tdc_css att */

.td_uid_14_5ba91ae82eb7c_rand{
margin-top:-11px !important;
margin-right:160px !important;
margin-left:160px !important;
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_14_5ba91ae82eb7c_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.td_uid_14_5ba91ae82eb7c_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

</style>
<style>
.td_uid_14_5ba91ae82eb7c_rand:before {
                    background: repeating-linear-gradient(-45deg, #cc4745, #cc4745 19px, transparent 10px, transparent 30px, #1c69ad 20px, #1c69ad 46px, transparent 40px, transparent 57px);
                }


                
                .td_uid_15_5ba91ae832111 button {
                    background-color: #ff0000;
                }
                
				.td_uid_15_5ba91ae832111 .tdn-title {
					font-size:20px !important;line-height:28px !important;
				}
</style><div class="tds-newsletter tds-newsletter7 td_uid_15_5ba91ae832111 tdn-input-bar-display-column tdn-style-bordered td-fix-index"><div class="tdn-info-wrap"><div class="tdn-info"><h3 class="tdn-title">Never Miss Any Linux News &amp; Tutorials</h3><p class="tdn-descr">Join Our Community Of Linux Lovers and Get a Monthly Newsletter in Your Inbox Directly.</p></div><form class="tdn-form" action="https://wiredmahir.us14.list-manage.com/subscribe/post?u=2275e1acb084ceef002b8abbd&amp;id=1bb07f20c8" method="post" name="mc-embedded-subscribe-form" target="_blank"><div class="tdn-input-wrap"><input type="email" name="EMAIL" placeholder="Your email address"></div><div class="tdn-btn-wrap"><button type="submit" name="subscribe">I Love Linux!</button></div></form></div></div></div><div class="vc_row_inner td_uid_16_5ba91ae8333b6_rand  vc_row vc_inner wpb_row td-pb-row">
<style scoped>

/* custom css */
.td_uid_16_5ba91ae8333b6_rand {
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }
/* inline tdc_css att */

.td_uid_16_5ba91ae8333b6_rand{
margin-top:-30px !important;
margin-right:160px !important;
margin-bottom:15px !important;
margin-left:160px !important;
padding-top:20px !important;
padding-bottom:21px !important;
position:relative;
}

.td_uid_16_5ba91ae8333b6_rand .td_block_wrap{ text-align:left }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_16_5ba91ae8333b6_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.td_uid_16_5ba91ae8333b6_rand{
margin-top:0px !important;
margin-right:0px !important;
margin-left:0px !important;
}
}

</style>
<div class="td_uid_6_5ba91ae833370_rand_style td-element-style"><style>
.td_uid_6_5ba91ae833370_rand_style{
background-color:#f4f4f4 !important;
}
 </style></div><div class="vc_column_inner td_uid_17_5ba91ae8336d8_rand  wpb_column vc_column_container tdc-inner-column td-pb-span12"><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_single_tags td_uid_20_5ba91ae833d28_rand td-pb-border-top td_block_template_9" data-td-block-uid="td_uid_20_5ba91ae833d28">
<style>

/* inline tdc_css att */

.td_uid_20_5ba91ae833d28_rand{
margin-bottom:3px !important;
}

</style>
<style>
/* custom css */
.td_uid_20_5ba91ae833d28_rand span {
                    margin-right: 4px;
                }
                
                .td_uid_20_5ba91ae833d28_rand span {
                    padding: 2px 8px 3px;
                }
                
                .td_uid_20_5ba91ae833d28_rand span {
                    color: #fff;
                }
                
                .td_uid_20_5ba91ae833d28_rand span {
                    background-color: #222;
                }
                
                
                
                .td_uid_20_5ba91ae833d28_rand a {
                    margin-right: 4px;
                }
                
                .td_uid_20_5ba91ae833d28_rand a {
                    padding: 1px 7px 2px;
                }
                
                .td_uid_20_5ba91ae833d28_rand a {
                    border: 1px solid rgba(0,0,0,0);
                }
                
                .td_uid_20_5ba91ae833d28_rand a {
                    color: #111;
                }
                
                .td_uid_20_5ba91ae833d28_rand a {
                    background-color: #ffffff;
                }
                
                .td_uid_20_5ba91ae833d28_rand a:hover {
                    color: #ffffff;
                }
                
                .td_uid_20_5ba91ae833d28_rand a:hover {
                    background-color: #ff0000;
                }
                
                .td_uid_20_5ba91ae833d28_rand a:hover {
                    border-color: #ff0000;
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.td_uid_20_5ba91ae833d28_rand a {
                    border: 1px solid rgba(0,0,0,0);
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.td_uid_20_5ba91ae833d28_rand a {
                    border: 1px solid rgba(0,0,0,0);
                }
}

/* phone */
@media (max-width: 767px){
.td_uid_20_5ba91ae833d28_rand a {
                    border: 1px solid rgba(0,0,0,0);
                }
}
</style><div class="tdb-block-inner td-fix-index"><ul class="tdb-tags"><li><span>Tags</span></li><li><a href="https://www.ubuntupit.com/tag/comparison-post/">Comparison Post</a></li><li><a href="https://www.ubuntupit.com/tag/distro-review/">Distro Review</a></li></ul></div></div></div></div></div></div><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator td_uid_21_5ba91ae834856_rand  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span></div><div class="td_block_wrap tdb_single_post_share td_uid_22_5ba91ae8349c8_rand td-pb-border-top td_block_template_9" data-td-block-uid="td_uid_22_5ba91ae8349c8">
<style>

/* inline tdc_css att */

.td_uid_22_5ba91ae8349c8_rand{
margin-top:-20px !important;
}

</style>
<style>
/* custom css */
.td_uid_22_5ba91ae8349c8_rand .td-post-sharing,
				.td_uid_22_5ba91ae8349c8_rand .tdb-share-classic {
					text-align: center;
				}
</style><div id="td_uid_22_5ba91ae8349c8" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.ubuntupit.com%2Flinux-or-windows-25-things-you-must-know-while-choosing-the-best-platform%2F">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Linux+or+Windows%3A+25+Things+You+Must+Know+While+Choosing+The+Best+Platform&url=https%3A%2F%2Fwww.ubuntupit.com%2Flinux-or-windows-25-things-you-must-know-while-choosing-the-best-platform%2F&via=UbuntuPIT">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/">
<div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
<div class="td-social-but-text">Google+</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/&amp;media=https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-25-Things-You-Must-Know-While-Choosing-The-Best-Platform.png&description=Linux+or+Windows%3A+25+Things+You+Must+Know+While+Choosing+The+Best+Platform">
 <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Linux or Windows: 25 Things You Must Know While Choosing The Best Platform %0A%0A https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/&title=Linux or Windows: 25 Things You Must Know While Choosing The Best Platform">
<div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
<div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/&text=Linux or Windows: 25 Things You Must Know While Choosing The Best Platform">
<div class="td-social-but-icon"><i class="td-icon-telegram"></i></div>
<div class="td-social-but-text">Telegram</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vkontakte.ru/share.php?url=https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/">
<div class="td-social-but-icon"><i class="td-icon-vk"></i></div>
<div class="td-social-but-text">VK</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Linux or Windows: 25 Things You Must Know While Choosing The Best Platform%0D%0Ahttps://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/">
<div class="td-social-but-icon"><i class="td-icon-line"></i></div>
<div class="td-social-but-text">LINE</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-viber" href="viber://forward?text=Linux or Windows: 25 Things You Must Know While Choosing The Best Platform https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/">
<div class="td-social-but-icon"><i class="td-icon-viber"></i></div>
<div class="td-social-but-text">Viber</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_22_5ba91ae8349c8">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div><div class="wpb_wrapper td_block_separator td_block_wrap vc_separator td_uid_23_5ba91ae835c72_rand  td_separator_solid td_separator_center"><span style="border-color:#EBEBEB;border-width:1px;width:100%;"></span></div><div class="wpb_wrapper td_block_wrap vc_raw_html td_uid_24_5ba91ae835d19_rand ">
<style scoped>

/* inline tdc_css att */

.td_uid_24_5ba91ae835d19_rand{
margin-top:-33px !important;
}

</style><div class="td-fix-index"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-format="autorelaxed" data-ad-client="ca-pub-4812623990144566" data-ad-slot="3305006843"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div class="td_block_wrap tdb_single_comments td_uid_25_5ba91ae835fa5_rand tdb-comm-layout2 td-pb-border-top td_block_template_9" data-td-block-uid="td_uid_25_5ba91ae835fa5">
<style>

/* inline tdc_css att */

.td_uid_25_5ba91ae835fa5_rand{
margin-right:170px !important;
margin-left:170px !important;
}

/* phone */
@media (max-width: 767px)
{
.td_uid_25_5ba91ae835fa5_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.td_uid_25_5ba91ae835fa5_rand{
margin-right:0px !important;
margin-left:0px !important;
}
}

</style><div class="tdb-block-inner td-fix-index"><div class="comments" id="comments"><div class="td-comments-title-wrap td_block_template_9"><h4 class="td-comments-title td-block-title"><span>39 COMMENTS</span></h4></div><ol class="comment-list"><li class="comment " id="comment-3248">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>colin pyper</cite>
<a class="comment-link" href="#comment-3248">
<time pubdate="1537690719">September 23, 2018 at 2:18 pm</time>
</a>
</footer>
<div class="comment-content">
<p>It is still Windows update that is causing the issues to these users. I have had friends who were quite content on Windows 7 with stable systems and one day found they had been &#8220;upgraded&#8221; to Windows 10 and some programmes that they depend on would no longer work at all. I have friends who were in boot loops and recovery options wouldn&#8217;t work. None of this crap was caused by anything the user did. Every case was Windows update forcing itself upon the system.</p>
</div>
<div class="comment-meta" id="comment-3248">
<a rel='nofollow' class='comment-reply-link' href='#comment-3248' onclick='return addComment.moveForm( "comment-3248", "3248", "respond", "5992" )' aria-label='Reply to colin pyper'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3250">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Andy Gait</cite>
<a class="comment-link" href="#comment-3250">
<time pubdate="1537690819">September 23, 2018 at 2:20 pm</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;None of this crap was caused by anything the user did&#8221;</p>
<p>More a case of what they didn&#8217;t do. Windows sent multiple pop-ups and warnings about the update. If people choose to ignore them and didn&#8217;t prepare, that&#8217;s not Windows fault. My mum was a case in point. She turned on her laptop one day to find Windows 10 there instead of 7. When I asked her if she&#8217;d had any warnings about it, she said yes, plenty of them, but just closed them down with really reading them.<br />
As for software issues, the only problem I had was my webcam stopped working, but then it was about 10 years old, so yes, it was annoying, but no surprise really.</p>
</div>
<div class="comment-meta" id="comment-3250">
<a rel='nofollow' class='comment-reply-link' href='#comment-3250' onclick='return addComment.moveForm( "comment-3250", "3250", "respond", "5992" )' aria-label='Reply to Andy Gait'>Reply</a> </div>
</article>
</li>
</ul>
</li>
<li class="comment " id="comment-3246">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>colin pyper</cite>
<a class="comment-link" href="#comment-3246">
<time pubdate="1537690592">September 23, 2018 at 2:16 pm</time>
</a>
</footer>
<div class="comment-content">
<p>A simple search for Windows 10 broken after the update will clearly show you are in denial of reality. I have had to recover files and reinstall windows 10 for several friends this year.</p>
</div>
<div class="comment-meta" id="comment-3246">
<a rel='nofollow' class='comment-reply-link' href='#comment-3246' onclick='return addComment.moveForm( "comment-3246", "3246", "respond", "5992" )' aria-label='Reply to colin pyper'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3249">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Andy Gait</cite>
<a class="comment-link" href="#comment-3249">
<time pubdate="1537690761">September 23, 2018 at 2:19 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Search for any fault on any product and you&#8217;ll find something. Look for Windows, Linux, or mac faults and you&#8217;ll find plenty. No OS is issue free or 100% perfect.</p>
</div>
<div class="comment-meta" id="comment-3249">
<a rel='nofollow' class='comment-reply-link' href='#comment-3249' onclick='return addComment.moveForm( "comment-3249", "3249", "respond", "5992" )' aria-label='Reply to Andy Gait'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3247">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Owen Iverson</cite>
<a class="comment-link" href="#comment-3247">
<time pubdate="1537690658">September 23, 2018 at 2:17 pm</time>
</a>
</footer>
<div class="comment-content">
<p>And a simple search for &#8220;Linux can&#8217;t&#8230;&#8221; or &#8220;Linux won&#8217;t&#8230;&#8221; yields???</p>
<p>You see how search results are not really a great metric for what we&#8217;re talking about? They&#8217;re more a reflection of (probably) people not knowing how to actually use the platform.</p>
<p>Personally, I&#8217;ve never had problems with Windows crashing itself since Windows 95 (when you still screwed around with jumpers and IRQ settings).</p>
<p>I would be curious about what your friends are doing, trying to do and how much more efficient they are when you move them to use Linux and running anything they need Windows for in a VM. Can you share how that&#8217;s been working?</p>
<p>I understand where we&#8217;re differing. You&#8217;re into tinkering and experimenting, which is perfectly fine. You&#8217;re not maintaining a base of users that are focused on production in a workplace.</p>
<p>I&#8217;m coming from commercial deployment where stability is paramount and change is almost always the enemy.</p>
<p>Configured properly, Windows is stable and not prone to crashing as you describe. I have 17 years of watching users work with computers and I can say first-hand that the average human is simply not ready for computers. Banging around in blind ignorance can bring any platform to its knees.</p>
</div>
<div class="comment-meta" id="comment-3247">
<a rel='nofollow' class='comment-reply-link' href='#comment-3247' onclick='return addComment.moveForm( "comment-3247", "3247", "respond", "5992" )' aria-label='Reply to Owen Iverson'>Reply</a> </div>
</article>
</li>
</ul>
</li>
<li class="comment " id="comment-3245">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Harold Guzman</cite>
<a class="comment-link" href="#comment-3245">
<time pubdate="1537690554">September 23, 2018 at 2:15 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Windows 10 is very good, but boot with 2.5gb RAM instead 500mb on Manjaro KDE. I have 64gb de RAM on Lenovo ThinkPad P50. In Linux my fingerprint doesn&#8217;t work, I need Adobe Suite.</p>
</div>
<div class="comment-meta" id="comment-3245">
<a rel='nofollow' class='comment-reply-link' href='#comment-3245' onclick='return addComment.moveForm( "comment-3245", "3245", "respond", "5992" )' aria-label='Reply to Harold Guzman'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3240">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>colin pyper</cite>
<a class="comment-link" href="#comment-3240">
<time pubdate="1537690315">September 23, 2018 at 2:11 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Windows is truly awful these days. So unstable it&#8217;s laughable. Using huge amounts of data to force updates that are highly likely to hose your system. That&#8217;s why you should run Windows as the VM inside a Linux environment.</p>
</div>
<div class="comment-meta" id="comment-3240">
<a rel='nofollow' class='comment-reply-link' href='#comment-3240' onclick='return addComment.moveForm( "comment-3240", "3240", "respond", "5992" )' aria-label='Reply to colin pyper'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3241">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Owen Iverson</cite>
<a class="comment-link" href="#comment-3241">
<time pubdate="1537690349">September 23, 2018 at 2:12 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Are you still on Windows XP??<br />
All joking aside, can I ask what you&#8217;re doing that crashes Windows 10?<br />
Until the big software companies (for me it&#8217;s Autodesk) write for Linux, I have to run Windows for my profession.</p>
</div>
<div class="comment-meta" id="comment-3241">
<a rel='nofollow' class='comment-reply-link' href='#comment-3241' onclick='return addComment.moveForm( "comment-3241", "3241", "respond", "5992" )' aria-label='Reply to Owen Iverson'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3242">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>colin pyper</cite>
<a class="comment-link" href="#comment-3242">
<time pubdate="1537690384">September 23, 2018 at 2:13 pm</time>
</a>
</footer>
<div class="comment-content">
<p>it&#8217;s Windows that crashes Windows. Usually through Windows update forcing its notorious system trashing releases.</p>
</div>
<div class="comment-meta" id="comment-3242">
<a rel='nofollow' class='comment-reply-link' href='#comment-3242' onclick='return addComment.moveForm( "comment-3242", "3242", "respond", "5992" )' aria-label='Reply to colin pyper'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3244">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Andy Gait</cite>
<a class="comment-link" href="#comment-3244">
<time pubdate="1537690506">September 23, 2018 at 2:15 pm</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;Windows is truly awful these days. So unstable it&#8217;s laughable. Using huge amounts of data to force updates that are highly likely to hose your system.&#8221;</p>
<p>Not in my experience. Windows 10 is rock solid for me, and that includes running insider builds for 2+ years.<br />
I don&#8217;t have any issues with updates, can&#8217;t remember the last time it crashed. In short, Windows 10 is the best version of Windows ever IMHO.</p>
</div>
<div class="comment-meta" id="comment-3244">
<a rel='nofollow' class='comment-reply-link' href='#comment-3244' onclick='return addComment.moveForm( "comment-3244", "3244", "respond", "5992" )' aria-label='Reply to Andy Gait'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3243">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Owen Iverson</cite>
<a class="comment-link" href="#comment-3243">
<time pubdate="1537690473">September 23, 2018 at 2:14 pm</time>
</a>
</footer>
<div class="comment-content">
<p>So no specific instances? Just your view from working on Linux? I&#8217;ve been deploying Windows in an 80 user environment since 2002 and really haven&#8217;t seen the kind of apocalyptic problems that people complain about.</p>
<p>We ran Window 2000, XP, and currently still on 7.</p>
<p>Obviously, there would be viruses here and there, but only one (Melissa) that required restoring from backup.</p>
<p>Since then, the number of problems from Windows updates or from Windows crashing has been less than a dozen. The biggest problem is someone picking up some malware that resets their browser settings. You run something Malwarebytes and that&#8217;s it. That probably occurs a few times a year (and often with the same users).</p>
</div>
<div class="comment-meta" id="comment-3243">
<a rel='nofollow' class='comment-reply-link' href='#comment-3243' onclick='return addComment.moveForm( "comment-3243", "3243", "respond", "5992" )' aria-label='Reply to Owen Iverson'>Reply</a> </div>
</article>
</li>
</ul>
</li>
</ul>
</li>
</ul>
</li>
<li class="comment " id="comment-3239">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Ajit Bakre</cite>
<a class="comment-link" href="#comment-3239">
<time pubdate="1537690239">September 23, 2018 at 2:10 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Can you develop windows software on Linux if you are a programmer? If so, give at least 5 examples.</p>
</div>
<div class="comment-meta" id="comment-3239">
<a rel='nofollow' class='comment-reply-link' href='#comment-3239' onclick='return addComment.moveForm( "comment-3239", "3239", "respond", "5992" )' aria-label='Reply to Ajit Bakre'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3238">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Andy Gait</cite>
<a class="comment-link" href="#comment-3238">
<time pubdate="1537690208">September 23, 2018 at 2:10 pm</time>
</a>
</footer>
<div class="comment-content">
<p>I know this is an Ubuntu group, but man, this is a heavily biased piece. I use and enjoy both Windows and Ubuntu, people do. Get over it.<br />
There is no perfect OS, they all have pros and cons. At the end of the day, the best OS is the one that works best for you.</p>
</div>
<div class="comment-meta" id="comment-3238">
<a rel='nofollow' class='comment-reply-link' href='#comment-3238' onclick='return addComment.moveForm( "comment-3238", "3238", "respond", "5992" )' aria-label='Reply to Andy Gait'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3237">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Rendered Pixels</cite>
<a class="comment-link" href="#comment-3237">
<time pubdate="1537690112">September 23, 2018 at 2:08 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Simple. Dual boot until you know your way around your distro of choice. They have drivers. Some better than others AMD with Vulkan, AMD cards do pretty well.</p>
</div>
<div class="comment-meta" id="comment-3237">
<a rel='nofollow' class='comment-reply-link' href='#comment-3237' onclick='return addComment.moveForm( "comment-3237", "3237", "respond", "5992" )' aria-label='Reply to Rendered Pixels'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3232">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Dam lo</cite>
<a class="comment-link" href="#comment-3232">
<time pubdate="1537673187">September 23, 2018 at 9:26 am</time>
</a>
</footer>
<div class="comment-content">
<p>If you&#8217;re not already clear on your preference then the answer is Windows and win10</p>
</div>
<div class="comment-meta" id="comment-3232">
<a rel='nofollow' class='comment-reply-link' href='#comment-3232' onclick='return addComment.moveForm( "comment-3232", "3232", "respond", "5992" )' aria-label='Reply to Dam lo'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3230">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>C Rogers</cite>
<a class="comment-link" href="#comment-3230">
<time pubdate="1537672961">September 23, 2018 at 9:22 am</time>
</a>
</footer>
<div class="comment-content">
<p>Re: face mocap, a Google search turns up 5 different ones for Blender. The YouTube demos look pretty good to me. With eevee in 2.8 it&#8217;s going to be real time full texture PBR approximation in the viewport. Seems to me there is more reason to love Free Software every day, and less reason to complain. 🙂</p>
</div>
<div class="comment-meta" id="comment-3230">
<a rel='nofollow' class='comment-reply-link' href='#comment-3230' onclick='return addComment.moveForm( "comment-3230", "3230", "respond", "5992" )' aria-label='Reply to C Rogers'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3264">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3264">
<time pubdate="1537752865">September 24, 2018 at 7:34 am</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;Was looking at re-face, but I think it&#8217;s not real time. That is pretty crappy that you need Windows just for one animation feature. I wonder if it would work in WINE.&#8221;</p>
<p>yes, that is one of the parts that is pissing me off the most.</p>
<p>well, not one tool<br />
I gave up on making games until I could either find a tool that works on Linux or make one my self.<br />
at the end of the day, the problem was solved, it was just a matter of wait (and try and fail to make my tools in the meantime)</p>
<p>I tried to make an animation (like xiao) but decided to wait instead (wait until synfig improved enough, which never happened, but maybe I could do it on Godot)</p>
<p>I wanted to use a tool such as facerig, but nothing like that existed both on windows or on Linux, now it does exist on windows, but not on Linux.</p>
<p>I want to make my animations, but that is expensive as f***, but thanks to technology, things that used to require big teams in the past now are possible with less time/efforts/persons.</p>
<p>the issue is, for each tool that is ported to Linux, another three tools born on windows.</p>
<p>For example, I was hyped that unreal was ported to linux, but then I realized that some tools existed and I never knew about then, tools like live2D, or new tools were born such as vRoid.<br />
So for every good news that I receive, I receive 2/3 bad news, that is what is sucking my motivation if those were tools that won&#8217;t help me on my hobby projects or workflow for commercial projects, I wouldn&#8217;t mind, the issue is, they may do help a lot.</p>
<p>(well, to be fair, unreal isn&#8217;t a single tool, but a collection of many tools.)</p>
</div>
<div class="comment-meta" id="comment-3264">
<a rel='nofollow' class='comment-reply-link' href='#comment-3264' onclick='return addComment.moveForm( "comment-3264", "3264", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3265">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>C Rogers</cite>
<a class="comment-link" href="#comment-3265">
<time pubdate="1537752895">September 24, 2018 at 7:34 am</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;the issue is, for each tool that is ported to Linux, another 3 tools born on windows.&#8221;</p>
<p>It&#8217;s getting better. But yes, still slow. I just appreciate what has been done and help to make that stuff better on the Linux side. Patience seems to be paying off more and more lately, and Blender and Godot are great examples. I think crowdfunding helps tons, so for every tool you want on Linux, it&#8217;s worth letting the devs know. 🙂</p>
<p>Good luck with your projects, and sorry, I edited the last post I made, and answered more stuff, just hit post too early!</p>
</div>
<div class="comment-meta" id="comment-3265">
<a rel='nofollow' class='comment-reply-link' href='#comment-3265' onclick='return addComment.moveForm( "comment-3265", "3265", "respond", "5992" )' aria-label='Reply to C Rogers'>Reply</a> </div>
</article>
</li>
</ul>
</li>
<li class="comment " id="comment-3233">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3233">
<time pubdate="1537673289">September 23, 2018 at 9:28 am</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;Re: face mocap, a Google search turns up 5 different ones for Blender. The YouTube demos look pretty good to me. With eevee in 2.8 it&#8217;s going to be real time full texture PBR approximation in the viewport. &#8221;</p>
<p>i dont need PBR but that isnt the point.<br />
just because blender can render the screen in real time, dont mean the code to decide what pose your face is doing can run in real time.<br />
nor mean that you can bake it in real time.</p>
<p>for example, bake an pre recorded sound to an f-curves, is quite fast, but you cant use the built in function of blender to do it in real time.<br />
you have to dive into python to do it in real time (and search for an code that does that or write it your self)</p>
<p>i found a lot of solutions for face mocap for blender, but none of then seem to be real time or cheap (i cant afford if its too expensive).</p>
<p>also, many people parrot stuff like &#8220;oh, gimp an do everything photoshop can!&#8221; without have ever tried to use it for production or knowing what features are required for an certain task and what features gimp/photoshop have.</p>
<p>fourtunately, nowadays we have channels like davies media design teaching people the how to do thing X, or what can be done with the feature Y.</p>
<p>you said those google results solve the problem, but did you even tried then? saw what are the issues, the setup process, if it accept webcam as input or only an pre recorded video, and if it takes less than 40 mili seconds to process an frame (in order to update the face at 24 fps at least)?</p>
<p>facerig has tons of sucess cases, big youtube channels, small channels, if blender can do it, why no one is using it?</p>
<p>not that this prove anything, blender is much more powerfull than MMD yet many people use MMD because its easier to use (if you dont need realism, fluid sim, etc)</p>
<p>the point is, i have already wasted my time trying to find an alternative and failed, maybe i&#8217;m out dated and the solution was made &#8220;yesterday&#8221; and i didnt knew it yet, but if that isnt the case, dont assume i didnt tried already.<br />
try it for yourself and when you see that its working, then you can say i&#8217;m miss informed.</p>
</div>
<div class="comment-meta" id="comment-3233">
<a rel='nofollow' class='comment-reply-link' href='#comment-3233' onclick='return addComment.moveForm( "comment-3233", "3233", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3252">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>C Rogers</cite>
<a class="comment-link" href="#comment-3252">
<time pubdate="1537705346">September 23, 2018 at 6:22 pm</time>
</a>
</footer>
<div class="comment-content">
<p>just posted to help in case you hadn&#8217;t seen them. None of them are as expensive as the proprietary solutions, it might be noted.</p>
<p>Also, I have used GIMP in a production environment (Advertising &amp; Product design) for 7 years, and it&#8217;s not the big deal that Adobe users seem to think it is. There are definitely things for GIMP to improve, but they certainly don&#8217;t prevent anyone from making commercial quality graphics and photo editing. Also, they are improving, and for free. 🙂</p>
<p>That&#8217;s just my personal experience though. Different people have different requirements, and I agree it does no good to judge and berate each other about what tools we choose to use to get the job done.</p>
<p>I choose to use and help improve Free Software because I believe in user freedoms, but I totally get those who just want the extra convenience features of Photoshop over those in GIMP, Krita, etc., and consider that convenience more important than the 4 essential user freedoms. It&#8217;s for each of us to choose from.</p>
<p>No bad feelings amongst brothers here.</p>
</div>
<div class="comment-meta" id="comment-3252">
<a rel='nofollow' class='comment-reply-link' href='#comment-3252' onclick='return addComment.moveForm( "comment-3252", "3252", "respond", "5992" )' aria-label='Reply to C Rogers'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3262">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3262">
<time pubdate="1537752475">September 24, 2018 at 7:27 am</time>
</a>
</footer>
<div class="comment-content">
<p>(buying and putting up with Windows, buying and putting up with a proprietary 3D modeler).<br />
I don&#8217;t get your point, blender is available for Windows as well</p>
<p>&#8221; Also, the first one I saw was about 12 bucks&#8230; &#8221;<br />
so you find something that I couldn&#8217;t, what it was the name? (google show different results for different people, so I couldn&#8217;t find what you did)</p>
<p>and yes, I know blender is capable of lots of stuff, I already tried to make fluid/smoke on it, the results are impressive.<br />
the issue with realism is that </p>
<p>1) I don&#8217;t plan to do something with realistic graphics (i prefer the anime art style)</p>
<p>2)realism is fucking expensive, you can&#8217;t throw a realistic character in a non-realistic environment or have a realistic environment without a realistic character.<br />
you have to maintain the consistency on the assets, realistic stuff is cool, but expensive to keep this level of detail, so blender being capable of doing it means almost nothing for my projects.</p>
<p>&#8221; without the trappings of proprietary software (if they care about such things). &#8221;<br />
they don&#8217;t care about PS being proprietary, they don&#8217;t even know the definition of free/proprietary software and when they can&#8217;t afford something they pirate it.</p>
<p>&#8220;I&#8217;d rather have the occasional proprietary couch in my Free Software house, than a Proprietary house with Free Software furniture. &#8221;<br />
that is a bit relative&#8230;<br />
1) if I could, of course, I would choose the issue is when I can&#8217;t choose.</p>
<p>2)if an software is proprietary but save in an interoperability format (such as jpg, png, svg, FLAC, glTF) your content isn&#8217;t locked to only one provider, so if in the future an software that meets your requirements is developed as open source, you can migrate your content.</p>
<p>for example<br />
let&#8217;s pretend that technologies like print screen where impossible ( i know they are possible, but for the sake of the example.)<br />
if you had to chose between your images being locked as PSD forever, but you use Linux.</p>
<p>or your images are in an interoperability format such as png, but you have to use windows to run the software to create content, what would you choose?</p>
<p>lock your content forever in a format that only a proprietary software can open, or not lock the content but use a proprietary OS to run the software that creates the content?</p>
<p>if a software is free, you can port it to Linux, hire someone to port, or someone may port in the future, but if you locked you content just because the software run on Linux, it would be much harder to port the content later to an open format than port an open source software to Linux.</p>
<p>images are easy to deal with because you can print screen then, but what happens when you have a runtime such as flash?<br />
if you had to choose between targeting flash (despite the runtime being proprietary)<br />
but using a software that runs on Linux, or target html5, but using an software that only runs on windows, would you still prefer using Linux?</p>
</div>
<div class="comment-meta" id="comment-3262">
<a rel='nofollow' class='comment-reply-link' href='#comment-3262' onclick='return addComment.moveForm( "comment-3262", "3262", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3263">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>C Rogers</cite>
<a class="comment-link" href="#comment-3263">
<time pubdate="1537752620">September 24, 2018 at 7:30 am</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;I don&#8217;t get your point; blender is available for Windows as well.&#8221;</p>
<p>The point is if what you want only works on Windows (mocap face thing you use), then Windows is part of the software requirement. That&#8217;s a big requirement. 🙂</p>
<p>&#8220;Also, the first one I saw was about 12 bucks&#8230; &#8221;<br />
so you find something that I couldn&#8217;t, what it was the name? (google show different results for different people, so I couldn&#8217;t find what you did)</p>
<p>Was looking at re-face, but I think it&#8217;s not real time. That is pretty crappy that you need Windows just for one animation feature. I wonder if it would work in WINE.</p>
<p>&#8220;1) I don&#8217;t plan to do something with realistic graphics (i prefer the anime art style)&#8221;</p>
<p>Plenty of toon shaders in Blender. But you probably know that. 🙂</p>
<p>&#8220;they don&#8217;t care about PS being proprietary, they don&#8217;t even know the definition of free/proprietary software, and when they can&#8217;t afford something, they pirate it.&#8221;</p>
<p>Yep. Sad I think. It&#8217;s like stealing a proprietary TV when a free one can do the same job. Is wrong and unfortunate on so many levels. 🙂</p>
<p>&#8220;1)if I could, of course, I would choose the issue is when I can&#8217;t choose.&#8221;</p>
<p>Yes, can&#8217;t choose is a problem. Though when people tell me I can&#8217;t, I often do anyway just to see if I can.</p>
<p>&#8220;2)if the software is proprietary but save in an interoperability format (such as jpg, png, svg, FLAC, glTF) your content isn&#8217;t locked to only one provider.&#8221;</p>
<p>PSD construction files can have hundreds of layers. It&#8217;s not easy to export all layers to formats which can be used without Photoshop. However Krita does an excellent job, and GIMP does a decent job for now. It&#8217;s not the export that is the problem; it is the construction files. Once again FOSS saves the day. 😀 The same can not be said of InDesign files, however.<br />
So yes, that is a problem of proprietary software. </p>
<p>&#8220;lock your content forever in a format that only a proprietary software can open, or not lock the content but use a proprietary OS to run the software that creates the content?&#8221;</p>
<p>The scenario makes no sense to me. I prefer to use both free software and OS to prevent such problems. What free and open source software only works on Windows and must be used because there is no alternative? 🙂</p>
<p>&#8220;images are easy to deal with because you can print scree.n&#8221;</p>
<p>Noooo, this is not a good way to save images. Lol.</p>
<p>&#8220;if you had to choose between targeting flash (despite the runtime being proprietary)<br />
but using a software that runs on Linux, or target html5, but using software that only runs on windows, would you still prefer using Linux?&#8221;</p>
<p>Again, this choice makes no sense. The very nature of Free Software means that it can be compiled for any OS which has a compiler for the code.</p>
<p>I will live in my free house and occasionally sit on a proprietary chair if I want/need to. 😉</p>
<p>To each their own.</p>
</div>
<div class="comment-meta" id="comment-3263">
</div>
</article>
</li>
</ul>
</li>
<li class="comment " id="comment-3255">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3255">
<time pubdate="1537705969">September 23, 2018 at 6:32 pm</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;None of them are as expensive as the proprietary solutions, it might be noted.&#8221;<br />
facerig is 6.90 dollars in my country, one of those solutions was more than 1000 dollars&#8230;</p>
<p>&#8220;There are things for GIMP to improve, but they certainly don&#8217;t prevent anyone from making commercial quality graphics and photo editing. &#8221;<br />
It definitely can, what we were missing was tutorials like the ones by davies media design youtube channel, instead of people that spread the word but can&#8217;t even use the software and market it as something they are defending due to ideology rather than quality.<br />
we need tutorials and success cases to convince more people to use it.</p>
<p>&#8220;. Different people have different requirements, &#8221;<br />
indeed.</p>
</div>
<div class="comment-meta" id="comment-3255">
<a rel='nofollow' class='comment-reply-link' href='#comment-3255' onclick='return addComment.moveForm( "comment-3255", "3255", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3256">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>C Rogers</cite>
<a class="comment-link" href="#comment-3256">
<time pubdate="1537712904">September 23, 2018 at 8:28 pm</time>
</a>
</footer>
<div class="comment-content">
<p>&#8220;facerig is 6.90 dollars on my country, one of those solutions was more than 1000 dollars&#8230;&#8221; How much was your 3D modeler? Also, the first one I saw was about 12 bucks&#8230; those not good enough? I mean, up to you, but it seems to me a lot of overhead (buying and putting up with Windows, buying and putting up with a proprietary 3D modeler).<br />
If it were me, I&#8217;d explore at least the cheap solutions before giving up completely and going to Windows. Also, your review of the plugins vs facerig would be valuable in helping the devs develop better plugins for Blender. 🙂 Anyway, totally up to you. I support you using whatever you like best. Also, even if you don&#8217;t need pbr materials, you get things like lighting smoke, fog, and reflections in real time in Blender 2.8.</p>
<p>Here&#8217;s a really nice example of what that does in an animation workflow: <a href="https://www.youtube.com/watch?v=nxrwx7nmS5A&#038;t=140s" target="_blank" rel="noopener nofollow">youtube.com &#8211; Tree Creature &#8211; Blender 2.8 development test</a></p>
<p>&#8220;What we were missing was tutorials like the ones by Davies media design youtube channel, instead of people that spread the word but can&#8217;t even use the software and market it as something they are defending due to ideology rather than quality.&#8221;</p>
<p>True. On the same note, I think people should definitely have tried GIMP before announcing the success or failure of a graphics program as a viable solution to get professional work done. Many Photoshop users will tout it as the only solution for professional work, which is not correct.</p>
<p>There&#8217;s not much benefit to arguing with them though. </p>
<p>Someone serious about learning new tools will ask questions like:<br />
&#8220;What can I do with GIMP&#8221; and then work to find out, rather than running to look up features that GIMP doesn&#8217;t have yet that Photoshop does while overlooking the features that GIMP can offer a designer as a free tool for bringing their creations to reality without the trappings of proprietary software (if they care about such things). </p>
<p>Anything else is just arguing over brands of a paintbrush, IMHO. 🙂</p>
<p>&#8220;I&#8217;m still trying, but not with &#8220;Linux only&#8221; on a game studio, but Linux machines were they can get the job done and windows machines were some software isn&#8217;t available for Linux.&#8221;</p>
<p>I +1ed your post about Cuphead working on Linux just now. I&#8217;m not a big gamer, but that game, in particular, is one I&#8217;ve been looking forward to playing. I&#8217;m happy I don&#8217;t have to put up with Windows to do it. 🙂</p>
<p>I&#8217;d rather have the occasional proprietary couch in my Free Software house, than a Proprietary house with Free Software furniture. Such is one of my (many) problems with using Windows.</p>
</div>
<div class="comment-meta" id="comment-3256">
</div>
</article>
</li>
</ul>
</li>
</ul>
</li>
</ul>
</li>
</ul>
</li>
<li class="comment " id="comment-3222">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Jan Helebrant</cite>
<a class="comment-link" href="#comment-3222">
<time pubdate="1537617102">September 22, 2018 at 5:51 pm</time>
</a>
</footer>
<div class="comment-content">
<p>My solution is currently Kubuntu Linux as the main OS and Windows XP in Virtualbox (offline) for few apps which do not have a usable alternative in Linux &#8211; like ABBYY Finereader etc.</p>
<p>For future, I bought Win7 Ultimate FPP so I do not expect problems. No games in my case and graphics/multimedia processing apps I use are available for Linux.</p>
</div>
<div class="comment-meta" id="comment-3222">
<a rel='nofollow' class='comment-reply-link' href='#comment-3222' onclick='return addComment.moveForm( "comment-3222", "3222", "respond", "5992" )' aria-label='Reply to Jan Helebrant'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-3219">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f9e5cca0953712dc32a92b33a345916b?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f9e5cca0953712dc32a92b33a345916b?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Michael Taggatz</cite>
<a class="comment-link" href="#comment-3219">
<time pubdate="1537616756">September 22, 2018 at 5:45 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Up to and including Windows 7 I have had such discussions, but since new hardware forces me to use Windows 10, these discussions have come to an end for me!</p>
<p>Linux is like owning a house on your own land, with a spacious cellar, an expansive garden, several balconies upstairs, a terrace with barbecue on the ground floor and many rooms, including a well-cut kitchen and several bathrooms.<br />
Of course, the distributions differ, sometimes even considerably. There is a distribution, for example, with two stairs to the first floor, a central, parental bedroom, with mirrored glass walls to the outside and a tour around it, in all corners a small bathroom and between the bathrooms, the children&#8217;s rooms.<br />
By the way, there is also a derived version, created by a very active community. The parents&#8217; bedroom has been transformed into a meeting room, three of the four bathrooms in the corners have been converted into kitchenettes and the children&#8217;s rooms into laboratories and offices.<br />
Other distributions pursue a completely new residential style or look like a factory, an office building, or a school.</p>
<p>Windows 10 corresponds to a seemingly comfortable apartment, with the most modern facilities, with kitchen and bathrooms that are constantly changing. Where there was a bidet yesterday, there is a rented washing machine today, the first 90 days are free! In the ultra-modern kitchen, on a huge LCD, suitable advertising spots are shown for every occasion, for which all storage cupboards and the refrigerator are supervised with cameras.</p>
<p>If you think it&#8217;s easy to get used to, I have to say I thought so until I realized that the walls and doors are made of paper, the apartment is surrounded by gambling machines, department stores, brothels, and supermarkets. The loud sounds of the gambling machines are the most striking, besides the sweet scent of the whores. But as I had to hear, sometimes Mafia pop groups take over the whole apartment. They throw the residents out of their own apartment until a ransom is paid.</p>
</div>
<div class="comment-meta" id="comment-3219">
<a rel='nofollow' class='comment-reply-link' href='#comment-3219' onclick='return addComment.moveForm( "comment-3219", "3219", "respond", "5992" )' aria-label='Reply to Michael Taggatz'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3220">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3220">
<time pubdate="1537616850">September 22, 2018 at 5:47 pm</time>
</a>
</footer>
<div class="comment-content">
<p>no one is saying that Windows is good.<br />
the issue is, the ecosystem is a killer &#8220;feature&#8221;<br />
I&#8217;m desperately trying to replace every tool of a functional workflow with alternatives available for Linux, but this is getting closer and closer to an impossibility.</p>
<p>(by workflow, I&#8217;m not talking about everyone workflow, but the tools that I need for my projects)</p>
</div>
<div class="comment-meta" id="comment-3220">
<a rel='nofollow' class='comment-reply-link' href='#comment-3220' onclick='return addComment.moveForm( "comment-3220", "3220", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
</li>
</ul>
</li>
<li class="comment " id="comment-3212">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3212">
<time pubdate="1537615837">September 22, 2018 at 5:30 pm</time>
</a>
</footer>
<div class="comment-content">
<p>dualboot&#8230;i mean, don&#8217;t get me wrong, but if we advertise Linux as an dual boot option, i think we have more chances to increase the market share than if we market it as an &#8220;windows alternative&#8221;</p>
</div>
<div class="comment-meta" id="comment-3212">
<a rel='nofollow' class='comment-reply-link' href='#comment-3212' onclick='return addComment.moveForm( "comment-3212", "3212", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3221">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Eric Buijs</cite>
<a class="comment-link" href="#comment-3221">
<time pubdate="1537617014">September 22, 2018 at 5:50 pm</time>
</a>
</footer>
<div class="comment-content">
<p>I understand the being pissed off part. Being judgemental about the choice of an OS isn&#8217;t very helpful. In my family, we use Windows, OSX and GNU/Linux. We do like to joke about that but I understand their choice so why would I doubt someones else&#8217;s. </p>
<p>I come from a complete proprietary environment but I began to dislike the &#8216;big tech&#8217; more and more after every upgrade and refused to throw away perfectly good hardware that wasn&#8217;t supported anymore. That&#8217;s when I started to take an interest in GNU/Linux.</p>
<p>Migrating to GNU/Linux can be cumbersome, time-consuming and sometimes frustrating. Finding the right software or building software from a source that isn&#8217;t available from the repository is a hit and miss (at least for me) but I do like the community feeling and I learned so much the last couple of years.</p>
<p>Thumbs up for the statement of Richard Stallman.</p>
<p>Cheers.</p>
</div>
<div class="comment-meta" id="comment-3221">
<a rel='nofollow' class='comment-reply-link' href='#comment-3221' onclick='return addComment.moveForm( "comment-3221", "3221", "respond", "5992" )' aria-label='Reply to Eric Buijs'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3231">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3231">
<time pubdate="1537673120">September 23, 2018 at 9:25 am</time>
</a>
</footer>
<div class="comment-content">
<p>In my case, i had a few tries with linux before starting to like it.</p>
<p>i used it once in some public computers, tried to download and run my games on it to show to a few friends and got frustrated that the system asked me, what program i should use to open an exe file (i thought .exe was some kind of self executable/assembly level bytecode that comunicates directly with the hardware and tha the system sucked for no simply runing it)</p>
<p> a few years later (or maybe prior) i used it on school, the teatcher didnt bother to explain to much about it, so i thought it was just an windows imitation that someone made because he thinked &#8220;if bill gates did windows and became rich i should do my own OS too!&#8221; and that it was just an waste of time that had to reinvent the whell on security etc instead of moving foward.</p>
<p>years later i gave another chance without even realizing it was the same thing.<br />
i was used to make my own homebrew softwares thanks to multimedia fusion (nowadays called clickteam fusion) i didnt knew much about programing, i thought that writing code was obsolete because everything they teach me at school i could easyly make clicking in the easy to use point n click interface of clickteam fusion, do all that an more, so i was just staring to see the point of lower level programing (i didnt knew that all programs were made in code includiong MMF, and that i wouldnt had to deal with MMF limitations if i dive on lower level)</p>
<p>at that time, my parents purchased 2 new computers so we could finally stop sharing a single old computer with 5 persons at home, but the issue was, they came with windows vista, in terms of hardware they should be much faster but thanks to Vista the notebook became slower than the old computer quite fast, the newer was faster but not blazing fast as the old computer when it was recently formated windows98, and the old computer died out of age.</p>
<p>then i started to searching for alternatives, i couldnt afford windowsXP with my allowance, i didnt want pirate since my parent could break the computer if he ever discover it, so i heard of linux and how it was made with colaboration in open source, and thought it was just an hobbyware as the softwares that i made, but thought it would be a cool experience to use/learn/contribute as an hobby, i thought some parts of the hardware may not work properly, maybe i would have to develop my own video drivers to make it work on my computer, but i thought i would know how to do it since i was used to make &#8220;hobyware&#8221; on MMF i thoght i knew what i was doing and that it would be easy to do.</p>
<p>to my surprise i didnt need to install a single driver, even my printer/scanner that took 2 hours to insall on windows (and instaled a bunch of crapware that try to make the life easier but only makes it harder) didnt even need to be installed on linux, it was just plug n play with an generic program to print and scan that worked for every printer/scanner instead of just this one.</p>
<p>back on the windows, i tried to find freeware or cheap alternatives to photoshop, coreldraw and others, since i wanted to make an game, need vector/drawing/animation programs but couldnt afford those and didnt want to pirate due to morals (ethical, being sucessfull without cheating), being afraid of being arrested and being afraid of distributing virus to my customers if i got any by using pirated softwares, nad being afraid of losing my data all over again due to virus.</p>
<p>in windows i couldnt find none of that, it had more softwares but that only made it harder to find any good that wasnt an ransomware- trial that pretend to be free only to lock your files created on it in a paywall, demos with limited features (aka you cant save), other crap softwares, softwares that came with an virus or adware-bar self instaling on browsers and good software that was too expensive for my pockets.</p>
<p>on linux i found great softwares with the built-in package manager that deal with updates (instead of each software making it own process to manage an updater, making the computer slower or not updating making it unsafe/without stability and speed patches)</p>
<p>and i knew that all of that was open source, wich made me see how good open source software could be and start supporting this ideolgy, even if some softwares had windows version i coulnd find it in the sea of crap that windows has and even the ones i knew (firefox) i didnt knew they were open source.<br />
even the screen savers were impressive and open!<br />
(but i never could understand the code of anything that i tried to read)</p>
<p>meeting linux was an &#8220;god&#8217;s gift &#8221; at an time that i was thinking it was impossible to make an homebrew game without cheating with pirate software.<br />
the only issue was&#8230; lack of an game engine, and lack of games.<br />
as for the games i didnt knew about steam (or had an international credit card that was required back then) many games that i wanted to play werent avaliable for pc anyway, the emulators i wanted were also avaliable for linux, so it was not an major issue at the begining.</p>
<p>as for linux game engines i tried a lot but none of then was good enough, they were either hard and undocumented or limited, i tried to look back on windows construct 1 was open source but windows only (and using windows only apis) back then, but i heard from a friend that clickteam started making it easier to pirate their software (MMF) to kill their competition, and aparently it worked, construct failed as open source so they decided to start over, this time as propritary and&#8230; their company is in a much more healthy $$ state right now, instead of stagnated without evolution.<br />
that was disapointed, open source seemed to be an solution for everything , but some companies had an better luck without it.</p>
<p>i entered an college for game making, and for the first time on my life i had an healthy social life with tons of persons arround talking the same languague, but i had to know more games to keep in touch with the conversations and to play with friends and understand the conversations i had to play games that only worked on windows again.</p>
<p>then i heard about steam and saw more and more games that used to be console exclusive being ported to windows, and being much cheaper on it , i tried to keep using linux, but only make me acumulate games to play, have Headache trying to install games, some times it worked with worse performance, sometimes the performance wasnt playable other times worked flawless, but the time i lost trying to make it work could be better spend playing more stuff or studying.</p>
<p>i tried to make my own game engine since i didnt had an good enough on linux, tried native but didnt knew how to distribute anyway, so tried to code for web and simply host the game online to distribute, but html5 was a bit imature and i didnt knew what i was doing.<br />
i tried HTML doom for the game and it was working (but that dont scale well, it became slow when the game get more complex and you cant manipulate individual pixels for special effects) , the audio api was not there so i tried a lot of experimental apis having to rewrite the code from times to times, tried to mix up an physics librarie, realized i need an asset- preloader otherwise the game would not always work (only if the pages were load twice and the scripts loaded in the right order)<br />
then i realized i need the canvas tag and audio api got stable, but managing the code was harder and only i used it (at least it was easier than trying to understand code from others and code that wasnt meeting the requirements at all) then i found an game engine in html much better than mine tried to migrate to it only to realized that none of my knowledge on canvas could be used to extend it (because canvas 3d/gl was different api from 2D canvas), the engine was cool an all but too limited so i would have to expand it before write my game, i couldnt wait anymore so started doing what i could before i add new features, but i lost my data again due to failure on the hardware (i&#8217;m still not used to versioning/backups) and i gave up on the engine anyway.<br />
being open source is great and all , but even an empty text document count as an open source software, what matters in the end of the day is if the software has the features that i need or if i would need to code it my self, and if the software will limit me later on.</p>
<p>i tried Unity since it was quite powerful, and then i meet godot , godot isnt as powerfull as Unity yet, but it has what i need for my personal projects and if i need an new feature i can add it since its open source.<br />
unity looks like an better option for comercial games since it has an massive asset store, so i&#8217;m sticking with those 2.</p>
<p>as for gaming, when valve announced steam machines they gave me a lot of false hopes.<br />
they ported a lot of games but my hardware was good enough to play those on windows but not on linux.</p>
<p>i hoped that all the games of the current gen would be ported (since that is what happens for every major game console, except for online games) and the old ones would be playable soon or later thanks to wine anyway, so i would be able to finalllly able to ditch windows, but instead the console was delayed and floped.<br />
looks like i developed some kind anxiety problems that lasts until now, in this mean time that i was waiting for steam machines launch only to get disapointed.<br />
valve didnt market it at E3 or at all, no one knew if they count it as pc or console, people were quite miss informed of what it was and many people didnt knew it existed since valve did no effort to market it at all and oems had no incentive since they wouldnt make a profit of games soud and could simply sell the same hardware with windows if the console floped, they had no reason to care about if it would flop or not and didnt bother to market it, or give reasonable reasons to chose it over the samething with windows.<br />
valve made no exclusives (and looks like they will stick with that strategy)<br />
linux users were satisfied as if we hadnt any problem in the gaming </p>
<p>(we have a lot of games! let ignore that most of then are indie and many dont worth your time&#8230;lets ignore all big titles launching and focus on the small ones we have, or ignore that the big titles came when an enhanced edition was already launched for other platforms, or an sequel or the performance was worse)</p>
<p>the games that used to be console only started being ported to windows and being much cheaper on it than buying an used old game and buying an old console, some emulators are windows excluvies or performs better on it, i learned about platforms that i didnt knew existed or that arcade versions were better than console versions and we didnt had emulators for some of those arcades on linux, and for those who use consoles to not having to use windows, that started making less and less sense.<br />
games like street figher5 you need an windows pc or ps4 to play, xbox exclusives was also avaliable for pc either , so, what is the point of spending more money into hardware (buying more consoles and and stronger pc), more money on games (sometimes with an inferior version of the game, or censored one without being able to instal patches/mods to remove the censorship), waste a lot of time and effort trying to make an game play knewing that it could crash or have graphical glitches at any time spoiling the experience, only to avoid using windows?</p>
<p>at the begining i saw the anoucment of some bomb indie titles&#8230;<br />
might n9 ! and will be avaliable for linux! (floped!)<br />
yooka laylee! and will have an linux version! (floped)<br />
blood stained! (still wating)<br />
but the issue is, almost no title that i care about so much as i cared about those were anounced for linux.<br />
i was happy to knew that i would be able to finally play disgaea only to realize that disgaea 1 will not be avaliable (so either i skip it, or i try wine or play on windows anyway) and only to realize that at the consoles they are already at disgaea 5 and i didnt even played the 1 yet!</p>
<p>ookami was ported to pc, not having to deal with emulators to try to try it! but not for linux.</p>
<p>looks like that for each 1 game that is ported to linux that i want to play, 5 are ported to windows.</p>
<p>and the same is happening with tools, unreal and unity being ported was great, but new tools, tools that would save me a lot of time on making the type of content i want to make are being born as windows only.<br />
(and make this is hard enogh to do with an small team, its even worse if you refuse to use the best tools avaliable just because they dont have an linux version, wich isnt done by those companies out of malice, even some open source tools dont have an linux version or cant afford to have the same level of support due to the small markethsare)</p>
<p>consoles may die in a near future (or be a machine for fools only) wich is a shame, MS having an monopoly isnt a good thing at all, consoles at least had all the multiplatform games from the current gen (plus a few exclusives)<br />
if valve had sucess entering this market with an open system instead of closed, linux would have all games from current gen, up to 150 millons of users and old games would run anyway thanks to wine, with more and more big companies making efforts to creating bridges, multiplatform code or improving wine to sell their games either on desktop or steam machines, with the performance being determined by how good the system is instead of marketshare.</p>
<p>that would make the system an viable option for more people on desktop and those niche aplications could be ported as an result or wine receiving more resources due to more users.</p>
<p>at least with consoles alive, gamers had an incentive to not give an monopoly to MS, and consoles were an market were games were used to not having old games so they wouldnt bother that much if steam machines didnt had those, but it would be a bonus if it had.</p>
<p>but steam machines floped&#8230;</p>
<p>how can i say it, it has being an roller coaster of emotions those years, trying to avoid windows becaming harder and harder, realizing that i would be able to play something only to think about it and realize that i would need to use windows to do so, trying to give up just to valve relase an bomb like proton-bomb creating me hope all over again.</p>
<p>and every time i complain about anything or admit to my self and speak open about it, saying that something isnt good enough yet (like the current linux ecosystem) i&#8217;m treated like an heretic.</p>
<p>so, i&#8217;m tired of that bullshit.<br />
volunteers arent obligated to do what i want or what i need, they are doing me a favor in doing so, and i&#8217;m not obligated of using linux and giving up lot of things as well, i&#8217;m doing a &#8220;favor&#8221; for then helping increase the marketshare, trying my best to create alternatives or wait until either an game/tool run on wine to use it, or the software/game is ported before i purchase it or for some one to create an alternative to it.</p>
<p>i can make some sacrifices in order to contribute to an better world tomorrow, but i cant sacrifice 99% of my confort, only 80%,70%,60%&#8230;.maybe 10%, cant measure.</p>
<p>the point is, i can deal with some sacrificing some confort in order to have more freedom, i had to do with to make the games that i want instead the games that an easy to use engine allow me to do, i had to do it in order to keep using linux, instead of being an microsoft slave.</p>
<p>what i cant deal with, is people trash talking me for not giving up all my confort for the gnu cause, even if i cant be sure it wouldnt be in vain, that isnt a lost cause (not as a whole but to expect to everything to conform)<br />
if an person think i should be obligated to use linux/free tools (otherwise i&#8217;m some kind of imoral, scum), that person should obligue her self to make the tools that i need to keep using it, or stop trash talking me.<br />
if she/he cant do it, she/he cant prove that what she/is is proposing is doable.</p>
</div>
<div class="comment-meta" id="comment-3231">
<a rel='nofollow' class='comment-reply-link' href='#comment-3231' onclick='return addComment.moveForm( "comment-3231", "3231", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3253">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/daee12b014ab0b00ec9c13210a31ac47?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Eric Buijs</cite>
<a class="comment-link" href="#comment-3253">
<time pubdate="1537705558">September 23, 2018 at 6:25 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Thanks for sharing igor. That was an interesting read. I&#8217;m not much of a gamer let alone a game developer and although free and open source software has become a big success, the game world is an exception. I hope this will change (and Godot is apparently a step in the right direction) but I understand that as a developer if you don&#8217;t have the (proper) tools you can&#8217;t do the work. No matter what others say.</p>
</div>
<div class="comment-meta" id="comment-3253">
<a rel='nofollow' class='comment-reply-link' href='#comment-3253' onclick='return addComment.moveForm( "comment-3253", "3253", "respond", "5992" )' aria-label='Reply to Eric Buijs'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3254">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3254">
<time pubdate="1537705675">September 23, 2018 at 6:27 pm</time>
</a>
</footer>
<div class="comment-content">
<p>thanks</p>
<p>I&#8217;m still trying, but not with &#8220;Linux only&#8221; on a game studio, but Linux machines were they can get the job done and windows machines were some software isn&#8217;t available for Linux.</p>
</div>
<div class="comment-meta" id="comment-3254">
</div>
</article>
</li>
</ul>
</li>
</ul>
</li>
</ul>
</li>
<li class="comment " id="comment-3213">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Peter Zimanyi</cite>
<a class="comment-link" href="#comment-3213">
<time pubdate="1537615966">September 22, 2018 at 5:32 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Why dual boot? Minimal install strong server and containers.</p>
</div>
<div class="comment-meta" id="comment-3213">
<a rel='nofollow' class='comment-reply-link' href='#comment-3213' onclick='return addComment.moveForm( "comment-3213", "3213", "respond", "5992" )' aria-label='Reply to Peter Zimanyi'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3215">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3215">
<time pubdate="1537616218">September 22, 2018 at 5:36 pm</time>
</a>
</footer>
<div class="comment-content">
<p>who said you gonna use it on a server instead of on a desktop? do you even know what tools the person will gona use?<br />
for example, there are no alternatives for VRoid on Linux<br />
No alternatives for Facerig (real-time face mocap)<br />
no alternatives for MMD (there are TONS of animators that use MMD since there are tons of assets in standard sizes, and famous characters for it in case the person wants to make an animation)</p>
<p>there are tons of specific niche tools.</p>
<p>tools to mod games/hack roms, to make games, music etc in a specific workflow, easy to use for a certain genre etc.</p>
<p>linux is freedom?<br />
what is freedom? do what you want when you want?<br />
in that case, windows give you more freedom since it has a broader ecosystem that covers more use cases.</p>
<p>see how the software works, modify and distribute? well linux is better at that, but that benefit software developers and only then.</p>
</div>
<div class="comment-meta" id="comment-3215">
<a rel='nofollow' class='comment-reply-link' href='#comment-3215' onclick='return addComment.moveForm( "comment-3215", "3215", "respond", "5992" )' aria-label='Reply to igor giuseppe'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3217">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/8ce0db2ceffa5951ef4cf1b517b66647?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Eric Buijs</cite>
<a class="comment-link" href="#comment-3217">
<time pubdate="1537616467">September 22, 2018 at 5:41 pm</time>
</a>
</footer>
<div class="comment-content">
<p>Actually, the freedom of free software is described in the four freedoms below. Of course, you are free to choose Windows and it&#8217;s abundance of software but with that, you&#8217;re giving up on the four freedoms below. For me, it&#8217;s more like becoming a vegetarian (or vegan) which is a matter of principle and not convenience. That&#8217;s not to say that I don&#8217;t respect or don&#8217;t understand Windows users.</p>
<p>The freedom to run the program as you wish, for any purpose (freedom 0).</p>
<p>The freedom to study how the program works, and change it so it does your computing as you wish (freedom 1). Access to the source code is a precondition for this.</p>
<p>The freedom to redistribute copies so you can help others (freedom 2).</p>
<p>The freedom to distribute copies of your modified versions to others (freedom 3). By doing this you can give the whole community a chance to benefit from your changes. Access to the source code is a precondition for this.</p>
</div>
<div class="comment-meta" id="comment-3217">
<a rel='nofollow' class='comment-reply-link' href='#comment-3217' onclick='return addComment.moveForm( "comment-3217", "3217", "respond", "5992" )' aria-label='Reply to Eric Buijs'>Reply</a> </div>
</article>
<ul class="children">
<li class="comment " id="comment-3218">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/f3ddd27e7f2f01339c9c93561bfb2814?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>igor giuseppe</cite>
<a class="comment-link" href="#comment-3218">
<time pubdate="1537616629">September 22, 2018 at 5:43 pm</time>
</a>
</footer>
<div class="comment-content">
<p>yes, I know what the 4 freedoms are.<br />
the issue is that Linux fanboys tend to only focus on those freedoms and ignore all the rest and that is pissing me off lately.</p>
<p>&#8221; but with that, you&#8217;re giving up on the four freedoms below&#8221;<br />
not really, some free software is only available for Windows (since Linux has a smaller market share)</p>
<p>and sometimes the software you need to finish your pipeline on Linux would be proprietary anyway, so you chose your poison (an free software on a proprietary system or an proprietary software on a free system)</p>
<p>it&#8217;s not like you always have a choice, if you had an unlimited budget to develop alternatives for everything that you don&#8217;t have an free software to do, that would be great.<br />
but how often that happens?</p>
<p>if you can complete your work using only free tools, that is great, but in a lot of cases you don&#8217;t or those tools aren&#8217;t good enough and you would spend too much time using then (and time is money)</p>
<p>in that case, the success of your company, project or product (or keeping the job) is more important than the freedom.</p>
<p>as stalman once said.<br />
&#8220;if you have absolutely no choice, use while you can&#8217;t get rid of it, then get rid of it as soon as you can.&#8221;<br />
I can&#8217;t remember the exact words but in some cases the cost of avoiding a software isnt a cost that you can afford.</p>
</div>
<div class="comment-meta" id="comment-3218">
</div>
</article>
</li>
</ul>
</li>
<li class="comment " id="comment-3216">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/189a1ba3e0c43be132fd96fe1e651a79?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Peter Zimanyi</cite>
<a class="comment-link" href="#comment-3216">
<time pubdate="1537616340">September 22, 2018 at 5:39 pm</time>
</a>
</footer>
<div class="comment-content">
<p>why use the desktop? I have everything on virtuals and work on Linux and win at the same time and 5 desktops per 300W can change to 40W think pc. I did not say what is freer. I say that on Linux I know how to build everything I need. what I do not want to do, or I will make some service as I need.</p>
</div>
<div class="comment-meta" id="comment-3216">
<a rel='nofollow' class='comment-reply-link' href='#comment-3216' onclick='return addComment.moveForm( "comment-3216", "3216", "respond", "5992" )' aria-label='Reply to Peter Zimanyi'>Reply</a> </div>
</article>
</li>
</ul>
</li>
</ul>
</li>
</ul>
</li>
<li class="comment " id="comment-2695">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/648b7a7a1b4e2c41921ec6a6e8df2ef9?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/648b7a7a1b4e2c41921ec6a6e8df2ef9?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Dale</cite>
<a class="comment-link" href="#comment-2695">
<time pubdate="1533565841">August 6, 2018 at 8:30 pm</time>
</a>
</footer>
<div class="comment-content">
<p>I definitely love Linux. I have been using it for years. What drew me to it was the open-source. As well, I love a challenge. I am still researching the best automation techniques for system and user cron jobs. My favorite is XUbuntu for my desktop because its lightweight in resources and highly configurable. I already have converted 8 people to Linux and have shown them how to use the software. I will use Windows, but sparingly because its costly to build a half-decent Windows system and the upkeep is time consuming.</p>
</div>
<div class="comment-meta" id="comment-2695">
<a rel='nofollow' class='comment-reply-link' href='#comment-2695' onclick='return addComment.moveForm( "comment-2695", "2695", "respond", "5992" )' aria-label='Reply to Dale'>Reply</a> </div>
</article>
</li>
<li class="comment " id="comment-2679">
<article>
<footer>
<img alt='' src='https://secure.gravatar.com/avatar/26032d1a6f75c58b7296eeea1a950b9b?s=50&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/26032d1a6f75c58b7296eeea1a950b9b?s=100&#038;d=retro&#038;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' /> <cite>Steven</cite>
<a class="comment-link" href="#comment-2679">
<time pubdate="1533501863">August 6, 2018 at 2:44 am</time>
</a>
</footer>
<div class="comment-content">
<p>Definitely Linux is better. Windows is slowly dieing.</p>
</div>
<div class="comment-meta" id="comment-2679">
<a rel='nofollow' class='comment-reply-link' href='#comment-2679' onclick='return addComment.moveForm( "comment-2679", "2679", "respond", "5992" )' aria-label='Reply to Steven'>Reply</a> </div>
</article>
</li>
</ol> <div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/#respond" style="display:none;">Cancel reply</a></small></h3> <form action="https://www.ubuntupit.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
<div class="clearfix"></div><div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div><div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent">
<input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" />
<label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label>
</p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='5992' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0ef87c93d8" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="220" /></p> </form>
</div>
</div></div></div></div></div></div></div>
<script>

			jQuery(window).load(function () {
				jQuery('body').find('#td_uid_1_5ba91ae8271cc .td-element-style').each(function (index, element) {
					jQuery(element).css('opacity', 1);
					return;
				});
			});

		</script>
<script>

				jQuery(window).ready(function () {

					// We need timeout because the content must be rendered and interpreted on client
					setTimeout(function () {

						var $content = jQuery('body').find('#tdc-live-iframe'),
							refWindow = undefined;

						if ($content.length) {
							$content = $content.contents();
							refWindow = document.getElementById('tdc-live-iframe').contentWindow || document.getElementById('tdc-live-iframe').contentDocument;

						} else {
							$content = jQuery('body');
							refWindow = window;
						}

						$content.find('#td_uid_1_5ba91ae8271cc .td-element-style').each(function (index, element) {
							jQuery(element).css('opacity', 1);
							return;
						});
					});

				}, 200);
			</script>
</div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Mehedi Hasan"></span><meta itemprop="datePublished" content="2018-08-05T00:17:59+00:00"><meta itemprop="dateModified" content="2018-08-09T19:04:55+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.ubuntupit.com/linux-or-windows-25-things-you-must-know-while-choosing-the-best-platform/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.ubuntupit.com/wp-content/uploads/2018/09/UbuntuPIT-Main-Logo-Linux-Fighter-Full-White.png"></span><meta itemprop="name" content="UbuntuPIT"></span><meta itemprop="headline" content="Linux or Windows: 25 Things You Must Know While Choosing The Best Platform"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.ubuntupit.com/wp-content/uploads/2018/08/Linux-or-Windows-25-Things-You-Must-Know-While-Choosing-The-Best-Platform.png"><meta itemprop="width" content="725"><meta itemprop="height" content="331"></span>
</article>
</div>
</div>



<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-5624" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5624"><a href="https://www.ubuntupit.com/comment-policy/">Comment Policy</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-32"><a href="https://www.ubuntupit.com/copyright-policy/">Copyright Policy</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-34"><a href="https://www.ubuntupit.com/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Copyright - 2018. All Rights Reserved. </div>
</div>
</div>
</div>
</div>


<style type="text/css" media="screen">
/* custom css theme panel */
.td_module_11 .td-read-more{
display:none;
}
.td-footer-wrapper {
padding-bottom: 0px;
}
.td-footer-wrapper .td_block_wrap,
.td-footer-info {
margin-bottom:0;
}
</style>
<div class="td-container"><link rel="apple-touch-icon" sizes="57x57" href="/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff"></div><!--[if lte IE 9]>
			<script>
				(function($) {
					$(document).ready(function() {
						$( '#ftwp-container' ).addClass( 'ftwp-ie9' );
					});
				})(jQuery);
			</script>
		<![endif]-->
<script type='text/javascript' src='https://www.ubuntupit.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.0.1'></script>
<script type='text/javascript' src='https://www.ubuntupit.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fixedtocOption = {"showAdminbar":"","inOutEffect":"zoom","isNestedList":"1","isColExpList":"","showColExpIcon":"","isAccordionList":"","isQuickMin":"1","isEscMin":"1","isEnterMax":"1","fixedMenu":"","scrollOffset":"10","fixedOffsetX":"0","fixedOffsetY":"50","fixedPosition":"top-right","contentsFixedHeight":"","inPost":"","contentsFloatInPost":"right","contentsWidthInPost":"250","contentsHeightInPost":"","inWidget":"","fixedWidget":"","triggerBorder":"bold","contentsBorder":"bold","triggerSize":"49","debug":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ubuntupit.com/wp-content/plugins/fixed-toc/frontend/assets/js/ftoc.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.ubuntupit.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=dc11e23cd0219f30e55307de07f135fc'></script>
<script type='text/javascript' src='https://www.ubuntupit.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script async="async" type='text/javascript' src='https://www.ubuntupit.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>
<script type="text/javascript">
         if (typeof wpquads_adblocker_check === 'undefined') {
             wpquads_adblocker_check = false;
         } else {
             wpquads_adblocker_check = true;
         }
      </script>

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[5992]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.ubuntupit.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.ubuntupit.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>
<script type="text/javascript">
      if (typeof ga !== 'undefined' && wpquads_adblocker_check === false) {
          ga('send', 'event', 'Blocking Ads', 'true', {'nonInteraction': true});
      } else if (typeof _gaq !== 'undefined' && wpquads_adblocker_check === false) {
          _gaq.push(['_trackEvent', 'Blocking Ads', 'true', undefined, undefined, true]);
      }
   </script>
<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
<header>
<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
</header>
<div class="tdw-content">
<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">
<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>
<textarea class="tdw-css-writer-editor td_live_css_uid_1_5ba91ae845283"></textarea>
<div id="td_live_css_uid_1_5ba91ae845283" class="td-code-editor"></div>
<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5ba91ae845283');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5ba91ae845283");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>
</div>
</div>
<footer>
<a href="#" class="tdw-save-css">Save</a>
<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>
<div class="tdw-resize"></div>
</footer>
</div>
</body>
</html>